Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

after year of running great, gray screen, headset not tracking after 1-3 minutes.


SWiT

Recommended Posts

My setup has been running great for over a year. I was running SteamVR beta. I got a firmware update indicator on my basestations and let it run. The first update attempt failed. The second attempt was successful. All of which could be coincidence. Immediately after running the updates and playing for the first time that day, after 1 to 3 minutes the headset goes gray and the SteamVR software says the headset has lost tracking. A reboot will get it to run for another 1-3 minutes then it grays out and looses tracking again.  I've switched back to regular non-beta Steam and the gray out happened after 30 seconds to a minute. Shortly after the headset looses tracking the basestations lose connection with SteamVR. I moved the base stations closer together with no luck.  I would like to roll back the base station firmware, but non-beta steam doesn't git the option. I have the basestations disconnected and connected to USB in CRP DISABLD mode. I don't know where to download different versions of the firmware.bin file.  I suppose it could be the headset having a hardware problems and have nothing to do with the basestations. Luckily I have access to a Vive at work so I will test my headset and cable tomorrow.

Basestations:

S/N: FA64JAA01497 ID:4307D153

S/N:FA64JAA00125 ID:E761E32F

 

 

Link to comment
Share on other sites

 

Hi, one thing you might try is connecting the sync cables. How far apart are your base stations?
If those changes don't make a difference, you can try this solution provided by Valve. Please read it all carefully before beginning.



The fix has worked successfully for several users, so we shipped the required files in the latest beta. You can find the files under your SteamVR install directory. The easiest way to get there is to right click on SteamVR in Steam, select Properties, click on the Local Files tab and Browse Local Files... Once there the firmware files live in:

tools\lighthouse\firmware\lighthouse_tx\archive\htc_2.0

You will need two files:

* lighthouse_tx_htc_2_0-calibration-rescue-244.bin
* lighthouse_tx_htc_2_0-244-2016-03-12.bin

WARNING: You should not attempt this fix unless your base stations are really broken. While it *should* be harmless, there is a non-zero chance it could make things worse. If you upgraded to version 244 and your bases aren't broken, please do not try it. This fix also applies only to HTC base stations, it will not work with older VDK1/Robin or the red laser Batman units.

The procedure is much like upgrading manually, but you do it twice, once with the fix-up firmware which will try to fix the base station, then once it has completed the fix, again with the current latest firmware.

1. With the base station unpowered, connect via a micro-B USB cable to your PC.
2. Hold the mode button down and plug in the power lead.
3. You can release the button once it enumerates as a USB mass storage device.
4. The drive will be called “CRP_DISABLED” and contain one file “firmware.bin”, delete that file.
5. Copy over onto the drive the “lighthouse_tx_htc_2_0-calibration-rescue-244.bin” file.
6. Once the copy is complete, pull out the power lead.
7. Wait a few seconds then plug in the power again. Be sure not to press the mode button while powering it up this time.
8. In a couple of seconds it should rapidly flash green or red. Green means it succeeded.
9. If it is flashing red that means it couldn’t automatically fix it and I’ll need to look at the unit to work out why.
10. Unplug the power again.
11. Repeat steps 1 thru 7 but using the “lighthouse_tx_htc_2_0-244-2016-03-12.bin” firmware file instead of the rescue one.
12. The base should now be working again, confirm by setting its mode to "A" and tracking with it alone (the other base turned off). Once it is confirmed working you can add back the other base.

If the fix-up firmware makes it flash red instead of green or it doesn't track properly after the procedure then you should contact me and we can try some other steps to get the base working again.

 

Thanks,

-John C

Link to comment
Share on other sites

Thanks you for your help.

 

The basestations are 15 feet apart. I tried moving them about 12 feet apart but that didn't help. Any closer would be a "non-solution" to me. I have been using the sync cable and channels A and B the whole time.

 

Just a few minutes ago I tested my headset with our Vive at work.  I swapped in my headset and cable, paired the controlllers, and everything worked great for 15+ minutes before I had to get back to work. The base stations at work are on the same version as my home basestations (436). I'm relieved to know it's not my headset.

 

Thank you again for letting me know where the firmwares are stored within Steam's folders. I will install the fix then the 244 firmware tonight. If it works I'll mark your answer accordingly.

Link to comment
Share on other sites

 I loaded the calibration fix firmware. Both basestations blinked the successful green. Then I flashed both to firmware 244. The problem persists. I tried using only one basestation on Channel A.  The headset still loses tracking after a few minutes. I can't even keep tracking long enough to complete room setup. The next step I'll try on my end is move the whole setup to a different room. Maybe let steam update the basestation firmwares. If I can't fix it tonight I'll barrow my basestations and link box from work tomorrow.

 

Link to comment
Share on other sites

Hi Swit.

Maybe check to see if your power options for your USB ports got turned on for power saving.

I had turned all my USB power saving off and for whatever reason, they got turned back on. Windows 10 does whatever IT wants. It reminds me of "The Borg" "We do it OUR way, your way is irrelevant" LOL :D

Take care

 

Regards: Jack

Link to comment
Share on other sites

I got it working last night!

The firmware update was a red herring.

Despite all the error messages and tests making me think it was losing tracking but still communicating over USB correctly. The problem was a USB 3.0 hub I've used as an extension in my room setup for almost a year. The hub seems to work fine other than it suddenly causing the vive to lose tracking after working fine for months. I picked up the Vive headset's USB port extender after I got the hub. So now I plug my wireless keyboard adapter into the back of my headset and no longer need the hub.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...