Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Direct Preview WiFi Issues


Edict
 Share

Recommended Posts

Let me start with something positive: I am able to connect the Focus 3 with the direct preview server.
The problem is that it stays at "Connecting...".

 

I keep getting an error in the direct preview log on the focus 3: ERROR streaming] [rrClient]OnVideoData() packet NULL pooIdx:-1

I am using the newest wave plugin version but I've also tried it with 4.3
I am using Unity 2019.4.12f1
I have an Nvidia Geforce 1080 & 2 screens
My coworker used the same steps and gets exactly the same result.

I've documented every step I took:

  1. install visual studio code

  2. install the adb file manager plugin and follow the tutorial to setup the plugin

  3. on your physical focus 3 device: stick something to the sensor right in the upper middle of the glasses so it won’t turn off while being connected to the computer or executing adb commands

  4. turn the Focus3 on

  5. connect the device to your computer

  6. make sure you’ve set up the environmental variable for adb

  7. open the command line

  8. type “adb tcpip 5555” (without “”) to start adb in network mode

  9. type “adb shell ip addr show wlan0”

  10. copy the ip displayed there. This is your focus 3 device ip which we will connect to

  11. type “adb connect INSERT-COPIED-IP” where INSERT_COPIED_IP = your copied ip

  12. unplug the USB cable from the focus 3

  13. open your unity project

  14. open the direct preview window through Wave -> DirectPreview

zi4psQs6-tghRO9f6Sdlor6Qof6arpNNYzilv_oO1JDgiLbS1AlSZIwA2GaJQh4mUtvty0KV55FodxYPQLX1Fcx09npvLhzJJ8gZqJC59JGbtPk34tj0crnnu2XIYfwtGUmAr5GviCru23uoPg

  1. set the connection type to Wi-Fi. USB does not work (some people say it only works through normal USB but I am using USB-C which did not work)

  2. in Device Wi-Fi IP type in the ip address that you copied before

  3. set the render target device to FOCUS+

  4. the default port that is being listened to is 6555. So open your router settings. If you’re using a fritz, the website is fritz.box

  5. go to your port forwarding settings and open the port 6555 for TCP & UDP

  6. open your advanced firewall settings

  7. add an inbound rule for the port 6555 as TCP and another one for UDP. You can call them as you like

  8. open visual studio code

  9. if you’ve set up the adb file manager plugin correctly you should see Android Device Files under the explorer tab. Go to the DirectPreview folder and open config.json 5NKabGqMbkBf3Lxh1cLqjjwMfBRw6XzMzNj9EJFSYC5IEqYx-BidiXgoH6tjpx_9Jk3mpvcB56Yv9n8BEdJ5HBw77NWXGX45Im1iX0Nljjrql_6SzkRpS0LGznFkwjV3lepgdF1aP1G8E2_QKAQUidPDFwRubOo_lhuq4WXh4rPw12LWquxGWgnNfJWs_lEQXVBPspUGCYNM9d4D4Ji3o1BTSWSZNfo3lU5JAF3ipwMPKUNvDXH2vxRuXbX8OvEtzcURvpNJXrjvG4GkDeucPGVCIhyrUE75pVUQ

rjCnfyegdQGTuWUWe9WaSZkyxi23XzsvjH4ewrgUymYZZCuZw1vo5uOS3G-0BoZq3-QiWl-bimMq6AGxes8aNsG2EpQNgvBQbTADdmTGZ52VBIBeXG4cu4-X4w7bDCklYD15zsthTp8knTu9xg

  1. Inside IP remove the IP address. This will by default be set to your local IP address but it is not possible to connect to local IP addresses through the direct preview

  2. go to the website https://www.whatismyip.com/de/

  3. copy the IP address that is shown there for you computer

  4. back in visual studio: paste the IP address that you just copied into the IP property. Do not forget to keep the “”

  5. save the file

  6. go back to the unity direct preview window and click on Start streaming server

  7. click on install device APK and wait until it was installed (several windows open and close)

  8. make sure your focus 3 is on and click on Start Device APK

  9. your focus 3 will now connect to your server. You can check if it worked by looking at the terminal that was opened. If it’s printing new messages then the focus 3 is connected

  10. to further check if there are any errors inside the focus 3: go to visual studio code and open the DirectPreview log OnQRKVC1HQ4HW_n6UaDaQOdXNAGgs8Pviu7BDF5AKmMt5nrX-nHlTGhGNCQZI3FdEg5niSTC0L9Di763DtJFSZOn0GqJeVNY3IrCh2-5b-pj8JXI-GPOXi2spsmhdYtM3gkdgL2bTGjrZBKDEQ

  11. hit play in the unity editor

Problems:

ERROR streaming] [rrClient]OnVideoData() packet NULL pooIdx:-1

On my end it seems like the focus3 is not able to connect to my GPU.

 

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I have same issue with direct preview  In the log I can see some activity beforehand showing that it is talking to my PC, but I ultimately end up with the same packet NULL error that you are seeing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...