Jump to content

Foveated Rendering does't work when output render texture is set (Vive Flow on Unity 2020 + Universal RP)


Danilo Delponte
 Share

Recommended Posts

Hi, we are working on a Vive Flow app and trying to add foveated rendering to improve performance. It works fine until we set an output texture on a 2nd camera, which is required for the experience we're building.

We tried with the Unity Built-In Standard RP and it worked, but we currently need URP.

Setup:
* Unity 2020.3.20f1 with Universal RP building to Vive Flow.

Find attached a sample project to reproduce this issue. It starts with two cameras and a few props, on the Vive Flow mobile input the left and right buttons toggle the 2nd camera output to a render texture, you can see the foveated rendering turning on and off. Press menu button to exit the app.

ViveFoveatedIssueSample.zip

Edited by Danilo Delponte
attached files didnt show up, trying again.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...