Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Focus 3 does not enter VR mode after running Unity application


jagoe
 Share

Recommended Posts

Hello,

I am trying to run an Unity application in VR on my Focus 3 using OpenXR. So far, I followed all steps in the VIVE Documentation regarding the installation of the VIVE OpenXR plugin and the setup of the Unity project.

Unfortunately, I encountered some problems during the building and deployment of the application. After running the application on the Focus 3, it does not follow the rotation or position of the headset. It seems that it does not even run in VR mode.

Do you have any idea what could cause this problem? I already tried to follow the official troubleshooting provided by HTC in the documentation.

Thanks for your help in advance!

Edit: For Debugging purposes I also tried to run an empty Unity scene with only one XRRig and a plane. The problem also occurs here.

Edited by jagoe
Link to comment
Share on other sites

I have probably found a workaround:
The scene loads properly if the Unity VR template is used. It can be selected in the Unity Hub. You just have to install the VIVE OpenXR Plugin for Android, as mentioned here and here. Some of the installation/setup steps can be skipped as the project settings are already adjusted for VR use.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...