Jump to content

Eye tracking in Unity stopped working after Vive software update

Recommended Posts

We had an old Vive software installed like a year or more ago and the eye tracking was working fine.

However, after we updated Vive software to get the OpenXR hand tracking with the Vive camera, the eye tracking fps is deteriorating to 40fps within seconds of the application start. Tracking calibration works normally and doesn't seem to have any issues. 

We also tried running on another PC with everything reinstalled. There, even a tested project crashes as soon as eye tracking in any of the variations is present in the scene: with OpenXR, SRanipal framework & SDK sample scene, SRanipal framework & sample code from the 120Hz thread. Similarly, the calibration tool is working just fine.


The working project is in Unity 2021.3.5, Win 11

We tried to make a test project in 2022.1.23 on Win 10  - no change.

Sranipal runtime, eye camera ver. 2.41.0-942e3e4

Vive OpenXR plugin 1.0.10

OpenXR plugin 1.4.2

XR Plugin Management 4.2.1

Vive SR SDK package v1.3.6.6 [also tried]


Does anyone have any suggestions on how to fix this?

Thanks in advance!

Link to comment
Share on other sites

Thanks for the suggestion. You got me thinking about the dependencies that lead to the source of the problem - the old SRanipal_runtime installation that was not fully removed/overwritten during the update. As I said in my post, we tried the newest SDK available already and the problem persisted. Our target application is actually using the OpenXR which was sufficient for our needs. So we were only SRanipal_runtime dependent and had 80-90 fps just fine. But after the installation of the new Vive Pro Eye software - first, the fps started to radically drop within the first 20s of work of the application. And since the major Steam VR update that got pushed to us yesterday, the eye tracking stopped working altogether.

The problem got resolved with a radical uninstall of everything that is Vive-related up to Steam VR, deleting all leftover files and registry entries, and reinstallation from scratch. I assume SRanipal_runtime of the older version was not correctly removed and the newer version couldn't start up (also it doesn't install in the same location as an old version, so we assumed it's not installed at all), which led us to attempts of reinstallation of the older version with a separate installer.

Consider the following steps to prevent the problem: add a note in the documentation that the new SRanipal_runtime is installed together with Vive Pro Eye software - it is NOT mentioned anywhere. Consider improving the check and cleanup of the older versions of SRanipal_runtime, since there is an obvious and reproducible conflict between the versions.

Thanks again!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...