Jump to content

Unresponsive storyplayer.exe - "Pearl"


Recommended Posts



I am facing issues with watching the google spotlight story Pearl on Viveport. Any help on getting this app running will be highly appreciated.


The app is able to load into the first two scenes, but then gets stuck on the 3rd scene, right after the scene change, when the music starts playing. In VR it seems like it is loading, with occasional single frames showing the actual scene and a couple seconds of music playing every 20s or so. However, i am unable to watch it, since it seems to never become responsive again.


During this hang-up theres no CPU activity, no GPU activity and the hard drive also does not seem to be busy. Only massive spikes in CPU and GPU activity when those single frames are shown.


Terminating the application is almost impossible, even through Windows task manager, or by forcing steamVR to quit.


Last time i was able to watch it was on June, 2017. Windows re-install, hard drive formatting and reinstalling viveport and "pearl" does not seem to help at all. Tried even starting Viveport as administrator with no help, even resetting SteamVR setting to their default values gave no results.


Its a real shame that this app is not working, as it is one of the best VR experiences and also a great demo for newcomers.

Link to comment
Share on other sites

     Hi ,


     I tried to replicate this on a handful of hardware and was unable to. Since the error happens after successful launch, it isn't something that would be related to the Viveport client. Nobody else has reported a similar issue which leads me to believe that the build we currently have on our servers is valid and that there is possibly some software or hardware quirk that is prevent proper playback on your end.


     Since it worked in the early summer it may be related to GPU drivers or SteamVR updates. Since it occurs when the music kicks in that may indicate that it's related to audio drivers or settings. Here are a few things I can think to try: 

  • Try turning reprojection off completely
  • Try running it with audio playback set to a device other than the HMD
  • Try launching storyplayer.exe via right clicking on it and running as admin (rather than just launching Viveport as an admin. It will be in the Viveapps folder under the subfolder "2bbf1a52-7b88-41fc-b06b-a8a5b0ee801f"
  • What GPU are you using? Perhaps reverting to drivers from prior to June could lead to a solution.

     I hope one of these works. Another option is to email Google Spotlight (spotlight.stories.info@gmail.com)  and see if they have any ideas. Pearl is awesome and I hope we can get this sorted

Link to comment
Share on other sites

Hi -- I have the same/similar issue.  I recently downloaded Pearl for my new HTC Vive,  the app seems to hang [steamVR says (unresponsive) storyplayer.exe ].  And some of the time, the audio starts playing, or even the laptop app starts showing the content, but in the VR headset it stays in the launching screen showing the title window, and the 3 rectangle loading bars.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...