Jump to content

Error 306 and 400 help!


Recommended Posts

I keep getting this error messages upon starting Steam VR. One message, on Steam Itself, that says "Steam VR failed to Initialized for unkown reasons. (error: Shared IPC Compositor Connect Failed (306)). The other Error is on Steam Vr Itself, it says, "Compositor is not available. You'll need this to run SteamVR to work correctly." Then their is a link to "Launch Compositor" When I do click on it, it does nothing. 

I have looked all around the internet trying to fix this.

I have a Laptop, Aleinware 17 computer that is able to run VR. I only have one HDMI port. Help would be great, thanks.

Link to comment
Share on other sites

Hi ,

This is a particularly challenging error code to troubleshoot as it typically has it's basis in how your PC's hardware and drivers are communicating with SteamVR and thus the solution varies from PC to PC. In some cases where you see this combo of codes, it's a conflict between which device (the GPU or your integrated graphics) is being chosen to drive the HMD. I'd mirror 's response and update your drivers as a first step. Uninstalling and reinstalling the drivers may help. Here is a guide that may help with that; be sure to toss in a reboot to ensure that all of the changes take effect. 

Link to comment
Share on other sites

Also, I've tried several things, found all round the web and the only thing that does anything different is disconnecting and deleting all USB data which then it either works for a very short time, until I turn it off, or it brings up a different error message, "Cannot detect Headset." (I might have been said differently.)

Link to comment
Share on other sites

  • 5 weeks later...

I followed all the instructions and unfortunately, i am still here.

After reading comments and forum, i found that the problem might be with the way the graphic card is connected in my Alienware 17 R4.

I tried :

1. hdmi to hdmi : I always get error 306 and error 400. I reboot and try to find how to change the configuration in Nvidia control panel.

2. mini DP to mini DP : Because i found a guy on the web with an alienware and he succeed with the mini DP cable. But here I always get error 208. No HMD detected. the light turns red.


What do i have to do ? If you can help me and tell me if there is a solution with the alienware 17 R4.

Do I have to try a mini Displayport through adapter to hdmi ? 

(Fortunately my desktop works fine, but I was hoping to have a mobile solution as well.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...