Jump to content

Problem with Controller Trackpad. Need some help


Recommended Posts


That's strange. I'd recommend just clearing out the USB drivers and probably doing a SteamVR reinstall.


Remove All SteamVR USB Devices

The Vive system is composed of about 9 different USB drivers, including Bluetooth, controllers, camera, receivers and audio, among others. Due to different reasons, like software updates, change of connections, system updates or malfunction of a device, the USB drivers might get into conflict and reinstalling them is a good way to get everything back to its working state.

  1. Go to SteamVR > Settings > Developer.
  2. Click on Remove All SteamVR USB Devices.
  3. Once finished, the program will prompt a confirmation of the process.
  4. Disconnect the Link box AC Adapter and the Link box USB cable from the computer.
  5. Close SteamVR.
  6. Connect the AC Adapter back to the Link box and then connect the USB cable directly to the computer to a USB 2.0 port.
  7. Open SteamVR and check if all the devices all properly recognized, by going to SteamVR > Settings > USB > Refresh.
    1. These are the default drivers:


Vive Link Box:

·         Hub

·         Hub Controller

·         Bluetooth


Vive Headset:

·         Watchman Board

·         Camera

·         Audio Device

·         Main Board

·         Wireless Receiver 1

·         Wireless Receiver 2


Note: This list includes the drivers of the devices directly connected to the computer by USB, as it is the HMD and Link box. Controllers and Base Stations are connected to the headset through Bluetooth and then to the computer, so these devices are not going to be visible on this list.



-John C

Link to comment
Share on other sites

  • Replies 60
  • Created
  • Last Reply
  • 2 weeks later...

Major Update - PLEASE READ, I really need help:


So, after the dozens of things that I tried to fix the input problem I was having, which included reinstalling all of Windows, installing a PCIE USB card to run seperately from the motherboard etc, I contacted the retailer that I bought the Vive from to sort out an exchange for another unit entirely, instead of going through HTC's RMA process. I gave them my old unit yesterday and the new one arrived today. Everything has been set up fine, Room Setup completed, all firmware updated, I test to see if I still have the problem and unbelievably I'm still getting the issue. I'm absolutely gobsmacked. I'm completely out of ideas of what's causing it. So we've established it's not a faulty unit as I'm using a new one, there's no problem in Windows as I wiped the harddrive and did a fresh install, and it's not some type of USB problem as I tried running it on a PCIE USB card (which was powered directly by the power supply through a 4-pin connector).

I'm losing my mind here, and really need some help figuring out what the hell is going on.

If you need a recap on what the problem is, or want a more detailed explanation, I'll restate it now: The issue I'm having is that either of the controllers will semi-frequently hang one of my inputs, not dropping it even if I physically released it. Originally I thought it was just the trackpad, but soon after I realised it was every single button.

Some examples:

1.) I touch the trackpad to move myself in games like Fallout, Payday, Pavlov etc, then release my thumb to stop moving but I carry on moving anyway. I will keep moving indefinitely. The only way to stop the movement is by making another input. Any input will cancel it out, such as pressing the grip button, or just touching the trackpad again.

2.) I tap the grip button in Fallout 4 to reload my gun, but instead I hear the unpinning of a grenade and look down to see a grenade in my hand. In this game, tapping the grip is bound to reload, and holding it for a certain amount of time will instead unpin a grenade. So it carried on thinking I was pressing the grip down even when I let go.

There are many other examples, but these are some of the more annoying ones. It all just comes down to the same concept of the controllers sometimes not realising that I've stopped making a certain input, and never ending it until I make another input to cancel it out, whether it be the same button or a different one.


I would really appreciate it if anyone could help me out here. I feel like I've exhausted every possible solution I can think of, and I have absolutely no idea what's causing it now.

Link to comment
Share on other sites

Thanks for the quick reply!

Funnily enough, that's exactly what me and my Dad were planning to do. His computer is good enough for the Vive, except for the graphics card. We're going to have to put my graphics card in. I'd be suprised if my graphics card is part of the problem. Hopefully anyway, so it should be fine to use it in his computer to test it.

And yes, the entire bundle was replaced. So, HMD, Controllers, Base Stations, Link Box etc.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...