Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Suddenly Missing Frames


Buckman71
 Share

Recommended Posts

I installed my Vive maybe, a week ago, was working fine with no issues whatsoever untill 2 days ago when I woke up, turned everything on and then it was missing frames like no tomorrow. Runnign SteamVR Home and being in the home environment is fine, doesnt miss a frame, but as soon as I launch a game, or even when I open the SteamVR overlay menu frames get constantly. Nothing had changed from when I went to bed, to when I tried to launch it the next morning, No updates, no software changes, nothing.

I know it isn'y my laptop because it was working flawlessly for almost a week and nothing happened until all of a sudden it decides to just drop frames. My drivers are all up to date, there are no Windows updates to be done.

 

Graphics Card: NVIDIA GeForce GTX 980M

Processor:  Intel I7-6820HK CPU @2.70GHz (8CPUs)

16GB of Ram

Windows 10

 

Context:

SteamVR Home only: Ip1hnZS.jpg
SteamVR Home with steam overlay menu(Same as with any game open):8BTntHW.png

 

Link to comment
Share on other sites

  • Replies 21
  • Created
  • Last Reply

Top Posters In This Topic

 

Hi John,

 

Chipping in to say that after updating to the newest SteamVR build, both of our development machines (identical specs) are also experiencing stuttering in not just the home environment, but in many different standalone VR applications, including the Unity editor. We tested that this does not happen with the previous SteamVR build (by using the second machine's SteamVR before updating it), and regardless of GPU driver version. This is also regardless of which SteamVR settings that are enabled, and we are not using the beta. Curiously, turning the VR dashboard on and then off again in a given scene application fixes the stuttering, but still, this is very annoying and is halting our development process.

 

Is there any way to revert to a prior version of SteamVR?

 

Here is a sample system report from one of the machines:

https://gist.github.com/anonymous/4db2bbe811c8e3f0dc70bc02ab3e2e7b

Link to comment
Share on other sites

 

After testing a few applications (and most importantly our Unity build), switching to the SteamVR beta actually seems to have mostly fixed it. There is still some of that nausea-inducing stuttering, but it seems to have restricted itself to loading screens now, so it doesn't happen in loaded scenes anymore.

 

Thank you!

 

Still though, the fact that we could so easily replicate the stuttering might indicate a more pervasive issue in the live SteamVR build.

Link to comment
Share on other sites

I have constant stuttering in home and gaming with the latest beta build when async reprojection is turned on. It works fine turning that off. The whole program seems to lag, even on desktop, with that on. Reverting to the non-beta version everything goes back to normal again.

Link to comment
Share on other sites

I've had both interleaved and async ticked together with no problems (I'd assumed it'd just choose async if it had it), but I tried unticking the interleaved and it made no difference. It's only unticking asynchronous reprojection that makes it all run 'wonderfully' again. Only in the beta though, fine in normal.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...