Jump to content

Vive Controller Bricked after successful firmware update?


Recommended Posts

I updated the firmware on both of my Vive controllers through the Steam VR Firmware updater on 4/14/18.  After the update, I unplugged the controllers from the PC and one of them would not power on, charge, or anything.  I have searched the forums here and on Steam, but the standard "Hold the 5 buttons for 10 seconds" and "Hold buttons, plug into PC, hold for 10 more" don't seem to work in this case.  The LEDs never come on at all to show any color no matter what buttons we push or hold.  Even when plugged in to the wall charger or PC no LEDs come on.


The only thing I can get it to do is when I plug it into the PC, if I hold the 5 buttons for 10 seconds and release,m it comes up as a mass storage device and I can browse to it and find a file named firmware.bin





Link to comment
Share on other sites

For those encountering this issue, I spoke with HTC Support via Live Chat.  They ran me through the basic, connect, unconnect, hold this button and that button.  About 40 minutes of this and they requested I plug in the controller and send them a picture to verify that the controller would not power on (as I told them it wouldn't in my initial message).  I did and they suggested I buy a new controller since it would cost about the same amount to have this one repaired.  Thing is, there are no new controllers to be had.  HTC is completely out of them, as per the Live Chat agent I spoke with.  They suggested Newegg.com but they are only selling them there via third party (not Newegg) for $170 usd.  This is pretty frustrating.  We are working on our VR game with a pretty tight deadline and without a second controller it is impossible to test for the Vive.  We may just go as an Oculus exclusive initially then enable Vive functionality once we can more hardware and test it.


You: I updated the firmware on my controller and once I unplugged it, it would not turn on or show any LEDs for status.
Maui: Hi! my name is Maui, Thank you for contacting VIVE technical support. How are you doing today?
Maui: Hi William!
You: Pretty good.
You: You?
Maui: That's good to know. I'm doing good. Thank you for asking. :)
Maui: Thanks for keeping us in the loop! Sorry that you are having an issue with your controller. Don't worry I can help.
Maui: To start with, are you getting error message from SteamVR?
You: No, Im afraid it doesn't register at all anymore in Steam VR
You: I can not get it to show LED colors anymore even if plugged in to the charger.
Maui: Oh, I see. Have you tried resetting the controller from SteamVR?
You: How would I do that?
Maui: Let's try this first. Press and hold the System button for at least 5 seconds and see if the controller turns on.
You: No reaction from the controller at all.
Maui: Have you tried charging the controller using the other cable and adapter, and plug the adapter into a different power outlet?
You: Yes, even then it does not light up an LED, the other controller does show to charge when using the same adapter and cable.
You: I have also tried other outlets and cables.
Maui: Let's try this step. 1. Using a micro-USB cable, connect the controller to one of your computer's USB ports. 2. From your computer, open the SteamVR app. 3. Once the controller is detected by the SteamVR app, follow the onscreen prompts to complete the firmware update.
You: Even connected to the PC, it shows that there is no controller on in SteamVR
Maui: Alright, then the next option that we are going to do is we will perform manual reset for your controller.
You: ok
Maui: Hold down the trigger, menu button, trackpad button, and grip buttons on the controller (everything except the system button). While holding the buttons, plug your controller into your computer with a microUSB cord. Wait for five seconds and release the buttons. IGNORE the new storage device that appears and unplug the micro USB cord to reset. Then start SteamVR and see if the controller is detected correctly and if it says there is a firmware update.
You: No, it just popped up CRP disabled, then I unplugged it and it still wont turn on.
You: SteamVR says controller not connected, make sure the controller is powered on and nearby, but it will not power on.
Maui: Oh, I'm sorry. Did you close SteamVR while doing the steps?
You: No, I will do that.
Maui: Let's close all SteamVR and end it as well from task manager.
You: Unfortunately same result.
Maui: Hmm, did you redo the same process while SteamVR is close?
Maui: Is that correct?
You: YEs
You: yes*
Maui: Alright. How about this can you plug the controller to the wall outlet and take a photo of it, please?
Maui: You can send it to this chat box. Please click on "More" then "Send File".
You: File Sent - 20180416_210517.jpg
You: File Sent - 20180416_210531.jpg
Maui: Thank you so much for that information.
Maui: May I know when and where did you purchase your controller?
You: I purchased from Vive.com on December XX, 2016
You: Forgive me, it was December XX, 2016 from HTC.com
You: Order Information Order Date: December XX, 2016 Order Number: XXXX
Maui: Thank you.
Maui: Upon checking with the receipt that you provided. It seems like your Vive is already out of warranty. However, you can still send the controller to our repair center, but there will be a possible quotation for the repair cost. or you can purchase a new one. I strongly recommend you to buy a brand new one, since the cost will almost the same.
You: We are currently developing a VR game, and there are no controllers available for purchase. We have looked several places online. Do you recommend where we could buy one?
You: We will have to stop development for Vive until we can find one to buy.
Maui: Well, upon checking you can get one from NewEgg. That is one of our Authorized Reseller. You can also check with Microsoft Store.
Maui: They are the ones who still have stocks for controllers.
Maui: You can also check for the other Vive Authorized Resellers: Microsoft stores Game Stop Micro Center Amazon Fry's NewEgg.com Costco stores Costco.com Abt Electronics Nebraska Furniture Mart Cyberpower HP (Hewlett Packard) B&H Photo BestBuy.com iBuy Power AAEFES Walmart.com Jet.com Office Depot MCX - Marine Corps Exchange
You: ok, I will check there, but it looks like Newegg isnt carrying them, it is someone else selling them for $167 instead of MSRP $129
You: I will keep looking though. Thank you for your time.
Maui: May I have your Zip Code, please?
You: 76033
Maui: Upon checking you can contact Microsoft Store to provide you their store that has stocks for controller.
You: I called all of them in this area and they have none, but I will check again tomorrow.
You: Thank you.
You: https://www.microsoft.com/en-us/store/d/htc-vive-controller/8pwfj5tw66pz
You: If you check "Find in Store" it shows "Unavailable" also
Maui: I really do apologize, however, we also don't have any stock from our end.
You: Anyway, I thank you for your time. We have an Oculus Rift here we can test everything on, and we will test it on Vive when we can get another controller.
You: Have a good day.
Link to comment
Share on other sites

  • 4 months later...
  • 1 year later...
  • 7 months later...

I know this thread is from a long time ago, however I ran into this same issue.

I ended up closing SteamVR, and then connecting the bricked controller, after about 30 seconds or so, SteamVR recognized that the device had a failed update, and brought up a message saying: "A device connected needs updated to restore it to a usable state." Click update. and then bingo. This didn't show up for a few days, but I guess you need to have SteamVR closed.


Make sure you do the button reset prior. (hold trackpad, one of the grip buttons, the trigger, and the button above the trackpad down for at least 10 seconds.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...