Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

VR Home works but games don't


Dyhhan
 Share

Recommended Posts

I set up my vive after having it off for awhile.  It was working before but now I can't launch games.  Also an error comes up when the steamvr app starts: "Compositor not fullscreen (-202)"  I can click the link that makes it fullscreen or wait until it goes away with the same result.

 

The startup app, Steam VR Home, works fully except for a few environments that seem to just not like me, but games won't load.  The game window on my desktop display is solid black with no response, the steamvr app displays the game as 'unresponsive,' the loading screen for the game is displayed on the hmd, and I can hear the game audio sometimes like it's running in the background but see nothing.  

 

Things I've tried:

-enabling/disabling direct mode, I have to run enabled to get anything to work.

-unhooking the vive and reconnecting it

-removing steamvr usb devices through settings menu

-restarting computer, this worked more often than reason would dictate in the past.

-reinstalling vive and steamvr software

-updating video card drivers

-rolling back video card drivers

-verify integrity of game files on old games that used to work and new games

Link to comment
Share on other sites

I've looked around and the answer seems to be to make sure both video feeds are coming from the graphics card and not the onboard gpu, but my computer doesn't have an onboard gpu so this isn't the issue.  Also in a new developement, the game will load on my computer monitor but I will only hear the sound sometimes and see nothing but a black window, the view in the hmd is the Home loading screen for the game.

 

SOLVED:  The problem was with unity switching resolution to 0x0.  The solution was to start the game that isn't working, while it's open change resolution of main screen to a different value then back again, then restart steamvr app.

Link to comment
Share on other sites

  • 1 month later...

Did you get this same message too?

 

Can you please let me know how to make the 0x0 resolution? My computer has a default graphic card of the Intel 620, and an add on of the NVDIA GTX 1060. Might be my problem here!

 

 

Link to comment
Share on other sites

, The way to get Unity to display the resolution selection menu if it's been hidden is to hold shift, ctrl, or alt while launching the executable. The actual key binding will vary depending on Unity version, developer implementation, keyboard layout...ect. 

 

The place you'd typically change the default graphics processor within Nvida's control panel is illustrated below. Your BIOS and other OEM software may complicate this - it tends to get very specific quickly with laptops. Be sure to check your BIOS.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...