Jump to content

Vive Pro Unknown USB Device


Recommended Posts

Alright so, let me preface this by saying that I've tried troubleshooting it for hours and I just can't get this thing to stop fussing.
So I was using my Vive Pro for about two hours, then I set it down to go and have myself a nap. During this time, the computer went into sleep mode and now the headset unrecognized by the system.

So I have this grand old problem where the device in the Device Manager/Universal Serial Bus Controllers is known only as Unknown USB Device (Device Descriptor Request Failed)


Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.


You know, that whole deal. Now no matter what port I plug it into, how many times I power cycle it, restart my computer, uninstall the drivers, manually assign the drivers or anything like that, it does not work.


Here's where it gets interesting!

The Vive Pro's red light is on, which tells me it has power. Additionally, the cameras are being picked up by things like Discord, and are fully functional. And we'll top that off with the controllers still sync to it when they are turned on.


But wait, there's more!

The standard vive headset works flawlessly using the same cords AND the same ports!

This implies that it's a driver issue with the pro, now the question is how does my computer going into sleep mode destroy the driver so badly I can't fix it?


I really enjoy using the Pro, I don't want to have to send it away or anything because of some ridiculous error.



Some more information. When SteamVR fails to detect the headset, I have tried rebooting it, and the service status message fails.

I have tried running different cords and everything, even going so far as to run the link box without the headset at all. This issue only arises when the headset is connected to the link box.

Every single time I put it into a new usb port, the only thing that installs is the camera. The rest fails to install.

Link to comment
Share on other sites

Unfortunately neither of those things have contributed results. Fiddling around with the driver types sometimes gets it to reinstall correctly, but only after a few tries. A friend of mine is having the same issue but only after a recent windows update. After any power cycle or sleep cycle, it begins to fail again.



I have fixed it once again by going into device manager, forcing it to install as a USB Composite Device, and then hitting update and search internet for driver. After doing this for about 15 minutes, it decided to install the correct ones. However I would not consider this a permanent solution. I still would like assistance in either understanding this problem or permanently fixing it.


Update 2

This no longer works.

Link to comment
Share on other sites

I've been doing an absurd amount of fiddling with it, and I was wondering if it's possible for either the cable or the link box to be responsible for this? Because the one thing that consistently gets it to fire up is to unplug the box completely, uninstall the drivers through SteamVR and restart, and then plug it all in. But this only works for ~10 minutes before the same issue re-occurs.

Link to comment
Share on other sites

Had the same problem, unknown usb device in device-manager. For another reason, i had to switch off my power supply yesterday. Now this unknown usb device is gone, Vive Pro working 100%. But Lighthouse 2.0 Basestations still not going into Standby (always on 24/7).

Link to comment
Share on other sites

  • 2 weeks later...

As i already mentioned, switching off the power supply to completely cut off power from the mainboard seemed to fix it for me (maybe the latest firmware update too). Before that, the unknown device always kept coming back as soon as i powered on the Vive pro connector box.

Link to comment
Share on other sites

  • 2 years later...

Hi Atiash

Well, nothing to worry about, to fix unknown USB device (device descriptor request failed), you can change the USB selective suspend settings. To do so, you need to follow the below steps:

  • At first, open the control panel and make a tap on power options
  • After that, select the option ‘show additional plans
  • Next, click on the “change settings that are currently unavailable" option.
  • Now, select the high performance & make click on ‘change plan settings
  • After that, choose the options Change advanced power settings >> change settings that are currently unavailable
  • Finally, locate the USB settings and then make a tap on it. Expand an USB Selective suspend settings. Disable On battery and plugged in.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...