Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Wireless Adapter Setup Install Issue: Fail To Install Displaylink


SleepyFruitBat
 Share

Recommended Posts

So I got the Wireless Adapter today, and I think I'm doing everything right, but when using the ViveWirelessSetup.exe application to install the app, I keep getting an error message that says: "Fail to install DisplayLink. Please reboot PC and try again." I've restarted my computer several times and it doesen't work. Advice or am I doing something wrong?

Link to comment
Share on other sites

Hello ,

 

Can you post your computer specs (make and model or if home built motherboard make and model, ram, gpu, OS)?

 

Curious if the installer during the download phase placed a DisplayLink folder here: C:\Program Files\VIVE Wireless\DisplayLink for you?  If so can you run the MSI file and select repair and let me know if that changes the behavior for you?

 

Thank you,

 

Link to comment
Share on other sites

Specs: ASrock x99 Chipset Motherboard, 32 GB RAM, Nvidia Geforce GTX 980, Windows 10 Home

 

During the Download Process, it did download a file right where you said, but when I used the only application in that file, DisplayLink XR, the install process was stopped by an error: "The installer failed to register the drivers with SteamVR. Check your Steam installation and try again."


Edit: On a gamble, I decided to uninstall and reinstall SteamVR and then try it again, this time succeeding and successfully managing to connect the headset once the installation was done. Thanks for pointing out that file, as I would not have been able to discover that solution without it.

Link to comment
Share on other sites

Moderator's note: In some cases, this appears to be caused by the SteamVR folder not being in the directory that the Displaylink portion of the installer package expects it to be. If you are experiencing this, aside from reinstalling SteamVR - it's seemingly important to install SteamVR to the location that the Steam client defaults to which is typically  C:\ drive which is often C:\Program Files (x86)\Steam\steamapps\common\SteamVR 

Link to comment
Share on other sites

  • 7 months later...
  • 1 month later...
  • 3 weeks later...

For me, the exact solution above didn't work. Uninstalling and reinstalling SteamVR didn't help. I tried to launch the msi file in the DisplayLink directory mentioned above and got the following error:

 

"The installation of DisplayLink software ended prematurely"

 

So, upon googling I found this link: https://support.displaylink.com/knowledgebase/articles/724494-cannot-upgrade-or-uninstall-displaylink-software

 

I downloaded the cleaner application, rebooted my system and it did not help either.

I didn't really feel like reinstalling Steam to my smaller C drive so I create a junction (symlink) in my c:\program files folder to the Steam folder. Here are some instructions: https://www.howtogeek.com/howto/16226/complete-guide-to-symbolic-links-symlinks-on-windows-or-linux/

 

I then ran the DisplayLink cleaner and rebooted, tried to reinstall and still got the same issues.

 

I then ran the cleaner again, then noticed that the c:\program files\Vive Wireless folder was still there. So I deleted that manually, then I cleared my temp directory as much as possible by deleting the files in c:\users\<my username>\appdata\local\temp. Then I went into device manager and uninstalled the Intel WiGig drivers.

 

Then I rebooted the system, and launched the original Vive Wireless installer and it worked!

 

I'm not sure if all the steps I took were necessary or which specifically helped the most but I feel like removing the drivers and deleting the Vive Wireless directory were key for me.

 

Hope this helps someone.

Link to comment
Share on other sites

  • 11 months later...

For me, all above did not work. Vive Wireless stopped working after a windows update.

I restored the restore point before the windows update, and it works again.

Working version:    10.0.18362 Build 18362

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...