Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Continual, ongoing problems with Vive Pro and USB 3.1


Dr_Mibbles
 Share

Recommended Posts

My company run several dozen Vive Pro, and since upgrading our VR laptops (MSI GT63 Titan 8RF) we are having continual issues getting the the Vive Pro to work consistently on any of them.

Our previous laptops were USB 3.0 and worked just fine. These new laptops use 3.1. That seems to be the only significiant difference.

Now, we are lucky to get a Vive Pro working for 10 minutes without issue. The only thing that seems to sometimes resolve it is running a fresh install of SteamVR every single time we start it up. But the second time you use it? Nah. Constant tracking issues, headset not being recognised, controllers not connecting etc.

 

I have tired everything I reasonably can and I am usually quite proficient at problem solving - reinstalling windows 10, USBdeview, etc. Nothing provides a lasting solution. This time I cannot get it working.

I'm not even sure who I should be seeking help from here. The laptop manufacturer (MSI) say nothing is wrong. The Vive Pro's work with USB 3.0 just fine. SteamVR sometimes allows them to run on a fresh install but is then of a mind to to let them work.

Should I just send all the laptops back and assume that USB 3.1 is not compatible with the Vive Pro/Steam VR? Is there some kind of fix? Has anyone else had anything like this issue?

It seems inconceivable that a product would be released and not tested on one of the most common USB 3.1 ports. Just astonishing that it could happen. Any assistance gratefully received. 

 

Link to comment
Share on other sites

I have a Win10 system.  Both wired and wireless (Vive Pro) work fine with 3.0 and 3.1.  *However* I have had similar issues in the past but they were intermittent.

 

I've had to do the uninstall/re-install thing but was eventually able to avoid this by playing with the settings in the device manager - remove device, refresh and let it re-detect.  This sometimes required a re-boot.

 

The headset or controllers will drop tracking/connection every now and then but almost never when being used - almost exclusively on SteamVR startup.  And re-booting will get them recognized.   And it almost always happens when I run Steam VR after activating the HMD and controllers.  Here is the typical process when I have a failed recognition:

 

1. Run SteamVR.

2. Activate HMD and/or controllers.

3. SteamVR Can't find anything.

4. Controllers quickly go to standby

5. Go into Steam VR (menu) and Reboot headset.

6. Quickly turn controllers on.

 

If that doesn't work, I:

 

1. Close Steam VR

2. Turn off HMD and controllers.

3. Run SteamVR

4. Activate HMD and controllers.

 

Both of these together take less than a minute or so.

 

Without seeing more details of your system, I would also (like mentioned) try messing around in the device manager.  One thing is, with the HMD off and Steam closed, uninstall the USB Root Hub then immediately let it re-detect and re-install.  Then try turning everything on.

 

(btw, I'm not in front of my VR system so this is off memory)

 

Link to comment
Share on other sites

Thank you but I already tried those things, and they don't resolve anything.

 

Some context:

 

Across twenty MSI GT62 7RE (USB3.0) = no issues

Across three MSI GT63 8RF (USB 3.1) = none of them work with the Vive Pro

 

Both types of laptop are running identical versions of windows, identical drivers, and identical SteamVR versions. The only meaningful difference is USB 3.1 v USB 3.0. 

Link to comment
Share on other sites

  • 1 month later...

Can I ask, which MSI laptop were you using?


On the MSI GT63 Titan 8RF, the model we have the issues with, it will sometimes work first-time after a fresh SteamVR install, but then, intermittent issues will keep appearing on pretty much every subsequent use.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...