Jump to content

Problem: Works perfectly one day, Unplayable the next (Pulsing Pixelation)


Squall
 Share

Recommended Posts

The Wireless will work perfectly for days and then next time you boot up the computer, randomly it can’t find the headset, so you reboot the headset over and over - no effect. Then I restart the computer. Then it will work but there will be this constant “pulsing” of pixelation and jittering when you move your head making it unplayable. Here’s a video showing it alternate from pixelated to clear constantly in Skyrim: https://drive.google.com/file/d/11NSVWgBxxnkk9Zd2uFsnvipyC4CsXlzZ/view?usp=sharing   I could not capture the jitter (when moving head back and forth) on the camera. Might have to see both screens simultaneously to notice that.

 

Please keep in mind, that I can supersample 180 - 200% with absolutely no slowdown whatsoever when this issue isn’t happening. The system is capable of playing games perfectly at 200% supersampling and has for hours and hours.

 

Now, when this issue happens, it doesn’t make any difference if you set the supersampling back to 100%. The CPU only goes to 40% and the GPU only goes to 60 - 80% during this. It never maxes out. Again, keep in mind, the system can work perfectly at 200% supersampling.

 

Somehow, it starting working again each time it has done this. What did I do to fix it?  The first few times, it seemed that switching to a new PCIe slot made it work again. It was in a 16x to start, then the next time it worked perfectly in a 1x, then I switched again and again. (It makes no difference what type of PCIe slot).

 

Later on, when this happened again, it seemed that rebooting without the card, then rebooting with the card back in allowed it to work again. I don’t know what fixed it. I’ve switched PCI slots, I’ve confirmed the PCIe slots run at Gen 3 speed. I have no other PCI cards in except the nvidia 1080i.

 

All the obvious stuff like distance, clear view of transmitter, etc is all fine. Remember, it’s been working perfectly at 200% supersampling for days and days, then it will have the issue, then somehow it works again (after many reboots, changing pci slots, sometimes giving up and coming back a few days later and then it just works or maybe not still). It appears to be software related because it works perfectly for days and then the next day back to the issue.

 

There is nothing else running.

The CPU is at 40%. GPU only goes to 60-80% when using the wireless adapter.

I have 64MB ram.

Even AVG and the Windows Indexing Service is off. There’s nothing else causing a load on the system. The headset can be cool or warm - doesn’t change anything.

 

It’s the most pixelated in Steam Home. Much less in Skyrim. And none in the white room. Video shows it’s constantly crisp and not pixelated in the white room: https://drive.google.com/file/d/1zUUQf0XttVsMj_OY6HPF3pB2dFjqTeFR/view?usp=sharing

The best I can describe it is pulsing pixelation - it’s perfectly clear one second, then pixelated the next second, then clear, pixelated - back and forth.

 

Please, before you respond  - remember, it has worked perfectly at the highest graphic settings and 200% supersampling on wireless. It’s not a hardware limitation. It has worked GREAT. It then randomly stops and gets pixelated. I don't’ run anything else on this computer. It’s build for Steam VR. It’s a brand new, clean computer.

 

When this “pulsing pixelation” happens, the little graph in the Vive Setting screen shows consistent purple spikes. Here’s a screenshot: https://www.screencast.com/t/tr364gsjDLQi When it’s working normally, there’s no purple spikes.

 

What can I test for you to narrow this down?

 

I’ve spent 15 - 20 hours troubleshooting this specific issue. Tonight I’ve spend 3 hours and cannot get it to behave normally again. Some more of the things I’ve tried:

  • Updated nvidia drivers
  • Tried SteamVR BETA. Using 1.27
  • Disabled anything else the computer doesn’t need to run SteamVR
  • Reinstalled Vive Wireless app
  • Reinstalled regular Vive install
  • Moved to a PCI slot closer to graphic card. Sometimes moving it from the 16x to the 1x made it work again. It’s got to be something with the software getting hung up.

 

It’s worked perfectly before these changes also. But when it gets stuck in this behavior, I try these things to try to kick it back into gear. Currently, I can’t get it back to normal. Please help. I’ve read other people’s blogs and posts who have a the same problem and no one has fixed it. People are returning or selling their headsets because it of it. I know my computer can run it - just need to figure out why some days it randomly stops working right. Thank you in advance.

 

Specs:

Intel i7-9700K

MSI Z390 Gaming Pro Carbon

Corsair H100i Pro 240mm Cooler

Seasonic 750w Gold PSU

Gskill TridentZ 64 GB DDR4 3200

MSI 1080ti Gaming X

Samsung 970 Evo 500 GB

Windows 10

Link to comment
Share on other sites

It's one week later and I have received no response from support.  I spent 2 hours last night trying to see if I could get it to stop the pulsing pixelation again. I turned off any Windows 10 process I thought could possibly be running something in the background: Cortana, Defrag (wasn't on anyway) and Nvidia Share, but who is going to do all that anyway?  Nothing helped.

 

I have the latest beta of Steam VR and latest drivers for everything.  I clicked the "remove all USB connections" or whatever from the Steam VR Developer settings and it reinstalled drivers - no effect. I've restarted dozens of times. Sometimes the headset would not be recognized even though it was on and connected to the Wireless app. It just appears random.

 

I've never heard of another product with this kind of random crazy, unsolvable issue where it's brand new and the computer exceeds the requirements by far. Again, the computer is super clean and lean. It's a problem either DisplayAdapter people or Steam needs to fix so people can have confidence in their product and buy and just be able to play it, not spend half the time trying to make it work. I'm still not able to play here. I can provide any logs or whatever is needed. I'd love for Steam VR to become reliable so it's the obvious choice for people.

Link to comment
Share on other sites

 I am in a similar situation, with a Vive whose performance is pretty awful when you consider the machine it is connected to(reprojection everywhere and FPS below 90 almost all the time, dipping as low as 45 at times). I also did a lot of test and was able to rule out the WiGig card (or PCIe slots) as I reverted to the wired HMD, but sadly the issues remain.

 

No more pulsating pixellation for me in wired(but I had this happen randomly ) but the performance in VR games is still way below what my hardware should be able to provide. If you happen to test to rewire your Vive, I'd be curious to know if the other issue you witnessed would recede.

 

Like you, I somehow suspect it's software related because for me, it's flawless in VR Home and Google Earth VR, but most other title have crazy reprojection as soon as I bump the supersampling even modestly (below the 200% recommended by Steam VR for my system)

 

My hardware (brand new hardware and fresh win 10 install / Steam / No bloatware, most of background stuff turned off)

Vive Pro Wireless or Wired (in my case, almost no difference)

ASUS WS Z390 Pro Mainboard

i9 9900K

32 GB Ram @ 3000 MHz

nVidia 2080 Ti FE

Samsung 370 Pro M.2 nvme

 

I don't know what to do or test at this point, the hardware works perfectly well in pancake mode, the benchmark results are consistent with the hardware, my CPU is never maxed out when I have bad perf... ?

Link to comment
Share on other sites

 

I haven't gone back to wired, but it always worked in wired. Your hardware is even better than mine and I can supersample 180 - 200 flawlessly when this thing wants to work.  

 

I also have a M.2 nvme drive - which I wondered: does that somehow use up the communication channels differently than a sad hard drive. Could that be causing the random pixelation. But what doesn't make sense is sometimes it doesn't do it at all and I've stopped more processes last night from running like anything likes Windows search indexing or defrag and from ever running and it's still doing it. But if I don't play the thing for her like a week and randomly reboot it'll work again for a day. And the next time I go try to play a game it says the headset can't be found and I will reboot and then it'll work but then the pixelation I'll be there.

 

There's got to be a way to pinpoint the pixelation. It's pulsing like something else is using up something on the computer. I hope I don't have to go back to wired but I might have to. Fortunately I did not have the issues that you're mentioning on wired, but shhhh - I don't want my Vive to hear that or it might start doing that too.  Thanks for sharing with me

Link to comment
Share on other sites

Similar issue here. New setup with specs close enough not to bother listing.

Vive Pro only about 4 weeks old and first three weeks ran perfectly with no issues at all. Now, about a week of screen flickering and periodic freezing.

No change at all to my physical environment and all hardware placement is optimal.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...