Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Vive headset stuck in a firmware update loop


Babish
 Share

Recommended Posts

I have a problem with my headset. When I launch SteamVr, It says that the firmware for the headset is outdated. When I do the update, it proceeds with the Watchman FPGA update. Then, after restating, it asks for the same update again. On the headset, the light is green, the displays lights up, but no images are displayed.

 

The weird thing is that the headset is working properly if I cancel the Vive reboot after the update is complete. The headset will then be functional until the next restart after which it will be non-functional and again asks for a firmware update.

 

I have already tried every standard procedures like resetting the firmware, different usb, switching cables, etc. I also tested the rest of my system with another headset and everything is working fine.

 

Any help would be appreciated, thank you.

Link to comment
Share on other sites

  • 3 months later...

Hello, I'm having the same issue and no (install/reboot/admin/other pc/USB2) seems to work.

Variation : I can't use it at all (display stays white)

Did you manage to solve this? I'd be really glad it you could post here the solution.

Link to comment
Share on other sites

  • 1 year later...
On 7/8/2019 at 12:05 PM, Synthesis said:

   

My guess is that there's a corrupted file on the headset. You'll want to send it in for repair. It probably needs to be wiped and flashed.

Thank you,
-Jack S

i have the same problem, and i have fixed it but unplugging the headsets HDMI cable, brung me back to the same problem and now im unable to fix it again. Why wouldnt we be able to repair it, wipe, and flash it without sending it to you guys?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...