Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Viveport won't install correctly


Carasano
 Share

Recommended Posts

When trying to install Viveport, I get an error saying that steam needs to close even after closing everything steam related through the task manager. I have tried starting SteamVR before the error shows, I have tried running as admin, and I have tried restarting. The Viveport application will download but the initial installation will not get past the error message. When trying to run Viveport, it bugs out and I can't interact with it (can't type in ZIP code when asked about store location and when prompted to get Vive Infinity, clicking on the buttons will not do anything).

Link to comment
Share on other sites

  • 6 months later...

I am running into the same problem. I have even uninstalled SteamVR, then uninstalled Steam entirely.  I even deleted the steam and steamapps folders in Program Files and rebooted.  But the VIVE Cosmos installer still INSISTS that I need to close Steam before it can continue.

Huh?

I'm evaluating whether Cosmos is a good fit for our future work, and we (and our clients) will be buying many more HMD's of whatever headset we pick. So far, Cosmos has been the worst to setup -- and I have tried this with Win7 (driver issues, and thinks I'm running Steam when I'm not) and Win10 (drivers installed, but still thinks I'm running Steam even after uninstalling Steam and rebooting).

 

@Synthesis

Link to comment
Share on other sites

  • 7 months later...

Still the same problem, with VIVE Pro. I was going to the site to install per directions it came with - well that was a nightmare as well. Finally just searched VIVE Pro and tried to log in, and that took another hour of "what in the world is going on?" Yet here i am, now i cannot shut down Steam. Is this even worth having? its been years and they cant get the setup correct yet? WOW!! Thank god it was free. 

Link to comment
Share on other sites

  • 1 month later...

@gumeroza - I generated a support ticket for you. In many cases, Steam can be hiding in the background - you can try using the task manager (CT-ALT-Delete) to manually close it. One other thing we commonly see is that people's installer can get stuck on the SteamVR installation portion of the installer because they have workshop content which can in some cases exceed 10gb+. I've seen a case where the installer stalled for someone and Steam was trying to install 125gb of Steam workshop content in the background so it's something to keep in mind.

Technically speaking, only SteamVR is the only thing required to run a Vive Pro and you can install that via Steam. There are some functionalities which require the Vive installer and usage of your included Viveport hardware bundle requires installation of Viveport.

Link to comment
Share on other sites

@gumeroza

I'd suggest reinstalling STEAM (don't need to delete games), completely remove viveport, restart your PC, then try a reinstallation, the fact it's screwing up means your STEAM IS BROKE. 

I never had to shut down steam when installing, it sounds like you have some windows issues, I'd suggest an SFC SCAN of your system directory, and some file system error checks, you can find tutorials on windows website, or you can do a windows repair via disk e.t.c (not recommended as the first step).
works for me perfectly fine, never had issues installed steam and viveport on 2 pc's 1 laptop! this is a USER ISSUE your device!

I promise 100% if you format your drive and reinstall windows and stuff, it'll work. (this always works) because of a system being RUINED! Proving it's not the SOFTWARE!

Edited by SanityGaming
Link to comment
Share on other sites

  • 7 months later...

@Cracatoa - The installer doesn't care what the internet source is, as long as it's reliable enough to pull data from the servers without connectivity issues. If you can't install on WiFi but can on Ethernet that may indicate a local problem with your network or your PC. I've installed Viveport on some pretty basic connections and have only had problems with WiFi when my latency is super bad.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...