Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Dirt Rally2.0 poor frame rate


pataan
 Share

Recommended Posts

After great difficulties (several BSODs) I was finally able to drive one special stage completely in Dirt Rally 2.0.

It was quite terrible, like driving on ice, not any feeling of the tyre grip on the road surface. The frame rate probably less than 20.

I put the graphics settings to medium or low, any other ideas for better frame rate ? 

Intel i7700, 16 gigs, Nvidia 2080 Super.

Link to comment
Share on other sites

37 minutes ago, TomCgcmfc said:

Best advice I can give you is to go back to Dirt Rally 1.0.  I bought this on a Steam sale for ~$10 recently.  The VR performance is much better, esp. with the Cosmos imho.  I'm just using a Xbox wireless controller btw.

I have Dirt Rally 1.0, but I could not play it with Cosmos. How did you get it work ?

Both 1.0 and 2.0 work great in 2d.

Link to comment
Share on other sites

58 minutes ago, pataan said:

I have Dirt Rally 1.0, but I could not play it with Cosmos. How did you get it work ?

Both 1.0 and 2.0 work great in 2d.

Ok, I checked this out again and DR 1.0 only has has Oculus Rift support.  About a week ago I got it working with my Cosmos using Revive and it seemed to work ok with my Xbox controller, but I did not think it was significantly better than with my Rift.  Based on current reviews (and fairly high price) I have not bought DR 2.0 btw,.  Based on what you're saying about performance I doubt I ever will, lol!

Since not all my Oculus library played very well with Revive (including with the latest Revive version which is supposed to be more Cosmos friendly) with my Cosmos controllers I ended up scrapping Revive for now.  For now I'm just running my Rift with it's library and my Cosmos for my Steam and Viveport libraries.  Actually, as long as I remember to power off  my Cosmos Link Box, I do not have many problems accessing all my Steam games, and most of my Viveport games with my Rift.  They often do not look quite as nice as with the Cosmos (adding some SS helps a bit).  However, because the Cosmos controllers still have very poor compatibility (even with many so called Cosmos ready ones) the gameplay with the the Rift touch controllers is generally a lot better.  At least for now.  Hopefully this will improve in the near future but until then I'm very glad I've kept my Rift installed and operational.  The only other thing I need to do is to with my Rift is to turn off the Oculus OVRservices before switching back to the Cosmos (I use OTT to do this) to avoid Oculus home trying startup with some Steam games, and independent flight sims.  Also, I generally need to go into my Windows sound setting and reset the Cosmos speakers to default.

  • Like 1
Link to comment
Share on other sites

I have made some progress with this.

First the not so good things.

I cant get this running from the Lens, the game icon appears there,
but when I click it, only the game introduction video starts to run and it runs endlessly,
the game does not start although I hit the start button.

I start the game like this:
- sign in to Steam
- start the Cosmos link box
- start SteamVR
- start the right controller
- start the game with the controller, by clicking the game icon

However, it is strange that the game does not start every time, sometimes simply nothing happens when I click the game icon.
Then I close the Steam and VR stuff and repeat the procedure, with the next attempt it usually starts.

Good news:

I was able to get a pretty decent frame rate with new graphics settings.

Previously I had made the graphics settings in the game when not having the VR on. But it is like the VR version would be a different game with its own specific settings.
When I found the graphics settings in the VR game I tried putting all of the settings as low as possible.
Then the game was running with quite good FPS. The image quality was not very good, but not too bad either.
Next step will be testing and finding settings that would give better graphics, but not hurting the FPS. 

Edited by pataan
  • Like 2
Link to comment
Share on other sites

11 hours ago, pataan said:

I have made some progress with this.

First the not so good things.

I cant get this running from the Lens, the game icon appears there,
but when I click it, only the game introduction video starts to run and it runs endlessly,
the game does not start although I hit the start button.

I start the game like this:
- sign in to Steam
- start the Cosmos link box
- start SteamVR
- start the right controller
- start the game with the controller, by clicking the game icon

However, it is strange that the game does not start every time, sometimes simply nothing happens when I click the game icon.
Then I close the Steam and VR stuff and repeat the procedure, with the next attempt it usually starts.

Good news:

I was able to get a pretty decent frame rate with new graphics settings.

Previously I had made the graphics settings in the game when not having the VR on. But it is like the VR version would be a different game with its own specific settings.
When I found the graphics settings in the VR game I tried putting all of the settings as low as possible.
Then the game was running with quite good FPS. The image quality was not very good, but not too bad either.
Next step will be testing and finding settings that would give better graphics, but not hurting the FPS. 

I had same problem before, but I found the button is "View details" not "Launch" later.

Btw, I thought lens is different from SteamVR. Maybe u can press Vive button on your CRs and see if it's what u are looking for lol.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...