Jump to content

HELP PLEASE: Device driver software was not successfully installed.


Recommended Posts

That is the message I have been looking at for the last 24 hours. I'm just installing my new HTC Vive and not having very good results.  The hardware is an Asrock Z77 Extreme 4 mobo with 16GB RAM and Windows 7 x64, which I have been using for several years but I'm not a gamer. When I decided I wanted to play with VR, I updated it with a 750W PSU and went from onboard video to a Zotac GTX 1080 AMP Extreme. The BIOS is the most current and all the mobo drivers are too, as far as I know (none of them have been updated in years so it seems like they ought to be pretty stable).


From what I can tell, it basically comes down to that one problem, the headset not being recognized or (for whatever reason) its driver will not install. After reading the forums and searching a lot, I have not made much progress. The only ground I've gained in the last 24 hours is at the one part of the ViveSetup.exe where it autodetects the USB and HDMI connection to the headset, my installation now detects the HDMI part but still no USB. I have tried ALL the USB ports on the machine, even installed more, to no avail. I currently have 6 USB ports on the motherboard back panel (two USB 2.0, two USB 3.0 Intel, two USB 3.0 Asrock). I also have two USB 3.0 ports on the front of the case. I also (due to last night's frustration) have a front panel assembly from another PC case hanging out the side with another four USB 2.0 ports on it). And, since none of that worked, I just installed an ancient 5-port USB 2.0 PCI card, but it fails in the same way.

Please note: All of these ports work - i.e. I can plug a flash drive into them and it shows up just like it should. Only the Vive headset is resisting. Furthermore, with the link box attached and recognozed as a hub, I can plug my flash drive into the USB connector for the headset and it shows up fine.


So doesn't this indicate that something else is wrong? Something with the specific driver or installation application? To me, my test seems to indicate good USB connectivity all the way to where the headset plugs in. Oh yeah, per some other web posts, I've also tried plugging the headset directly into the USB ports on the PS rather than the Link Box. No go.


I've also done the thing where you go in StreamVR/Settings/Developer and remove all the drivers then re-add by plugging back in. I've also sat here and simply plugged and unplugged a whole bunch of times in a whole bunch of ports because some people suggested that sometimes helps. And of course, I've uninstalled all the Vive stuff a bunch of times and the Steam stuff a couple times.


I am really frustrated but moreso disappointed because I thought this was going to be so cool...


Can somebody please help me out? Please please??


THANKS in advance!


Link to comment
Share on other sites

I bought another 4-port USB 3.0 card, Inateck KTU3FR-4P, because I saw in one of the FAQ pages where it was a card found to solve many of the kind of problem I am having. I've spent several more hours now plugging and unplugging the USB & power connections. Still no luck with getting my Vive operational. 


I had one quick minute of hope: I've been using step 2.2 of the Vivesetup.exe program, where it shows a USB connection and an HDMI connection and there are a couple of                                                               spinning arrows the just sit there trying to detect the two halves of the headset connection. Up until now I've only ever got the one spinner to stop (HDMI), partially passing the test while the USB test continued (school to spin).

I had been leaving Device Manager open so I could watch when I was plugging and unplugging. At one point, I had three or four Freso Logic devices (related to the USB card I just added), a Bluetooth BCM20703 (I think it is inside the Vive Link box). I noticed a new branch named "Other Devices"  and under it were two "HTC Vive" devies and a "Watchman Dongle", all three with yellow exercises). I unplugged and plugged again and saw a number of devices come and go and finally I noticed under "Imaging devices" that there was a "HTC Vive" with no exclamation point.


It attempted to run the room setup program, bur I got an error something like application not found (Steam error dialog - not WIndows), I went and found the application and sure enough there was a 64-bit version (I saw this suggestion on an Internet post). I ran the 64-bit setup program. It asked if I wanted a Room scale setup and I do. It told me to go find my controllers and by the time I got back, the "HTC Vive" has disappeared and I've not got it back again .


I don't know how to proceed. Oh, one more thing, on a long-shot I uninstalled VMWare desktop thinking it might have hooks in Windows USB code. No improvement. I also tried turning off a couple of BIOS settings related to "Legacy USB 3.0 Support". No improvement.


One more thing I did was, I found a post that inspired me to go into SteamVR/Settings/Direct Mode setting. I think it was when I DISABLED direct mode that finally the headset lit up and the LED on the side went from red to green and I held it up to my eyes and could see a blank Windows desktop in there, though it didn't look right because the headset had not been adjusted for my head/eyes. At least it was a relief to know that it can turn on and display light and images as output by the video card.


So, any ideas? Please? I forgot to metnion that from time to time I've tried to use Live Chat, and sent emails via the Vive feedback.exe program, hoping to be able to get in touch with someone who actually works for HTC/Vive. I have received no response so far. I really need some help because I am not making any progress and have just spent about $1500 for all this stuff that doesn't work. If I have to send it back I am going to be very disappointed. Thanks all. -Marty

Link to comment
Share on other sites

I saw a post somewhere from another person having the same nightmare experience with Vive as I. They upgraded their PC to Windows 10 and it fixed Vive.


I can't realy do that as I have work stuff that had problems on Win10. However, I had an old SSD laying around, so I installed it in my PC and put Win 10 on it. I, too, am now up and running Vive.


The VR experience is so cool that I am willing to put up with a kot of carp, but wow, what a wild goose chase. I wish they had just said it was not compatible with Win7.


I'm not sure how I will proceed but it is certainly a relief to know that the hardware can do it if the right OS is there.





Link to comment
Share on other sites

To heck with it. I get the feeling Windows 7 is about a million miles away from being able to run this software. After connecting the Viv cables, I saw so many devices being installed under Win10, and virtually none of these installed under Win7, even after days of plugging and unplugging and trying (literally) 24 USB ports, with possible exception of the Link Box being installed as a USB hub.


I hooked up a couple of long cables and have them sticking out the back of my case. When I want to play VR I'll just hook up the SSD with Win10 on it and for everything else I'll connect my old Win7 SSD. 


One thing I don't understand is that I ran the compatibility checker before spending any money. It said the "only" thing I was short on was video, so I ordered a Zotac GTX 1080 AMP Extreme.  When it arrived, I was all fired up to install Vive and have a great time. Laughably, like an idiot, that fun day was spent driving to a nearby city with a decent computer store so I could get a new case that would accommodate the video card and swapping all my PC's internals over to the new case. D'oh... I though that would be the worst of it. Back to the one thing I don't understand: why don't they either say it doesn't work on Windows 7 or provide a disk or file with the necessary drivers, or build them into the installer? As easy as it installed on Win10, it sure seems like it would be just as easy on 7 if the necessary drivers were available somewhere. Apologies to the programmers if I am trivializing something that is a much bigger deal.


Maybe these posts will help point someone else in the right direction.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...