Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Device Setup fails


Niel9533
 Share

Recommended Posts

I'm new.  I am trying to setup my device but when I choose the Vive I get the following error and cannot proceed.

 Requested operation requires elevation.

I run ViveSetup.exe as Administrator and Vive software & Viveport install goes fine - then I'm prompted to choose my device to setup and this is where it fails.  I'm running Windows 10

Thanks for your help

the requested operation requires elevation.PNG

Link to comment
Share on other sites

  • 4 months later...
  • 5 months later...
  • 1 month later...
  • 6 months later...

I just had exactly the same thing happen to me when I was trying to set the Vive Cosmos up on my work computer. I was using an administrator account and running Viveport as an administrator, but when I went to device setup I got the 7-Zip "The requested operation requires elevation" error.

I solved it by first running the Viveport desktop app as an administrator, then ignoring the device setup menu and instead going directly to the folder with the setup files and running the "App_Launchers_ViveCosmosSetupP2CHS.exe" file as administrator, which launched the device setup properly.

On my computer this folder was at: C:\Program Files (x86)\VIVE\Updater\Temp\com.htc.windows.oobe.launchers.1613717580769\assets

I was also able to find it by going to C:\Program Files (x86) and searching for "ViveCosmosSetup".

vive_setup_files.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...