Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Unity URP and Vive Focus 3 build with black screen


StaRky_FR
 Share

Recommended Posts

Hello everybody,

This is not really a message for support but mostly to help others since I resolved my issues after many tryouts.

 

I converted an Oculus Quest project (with dedicated sdk and all) to OpenXR to allow Oculus/Vive support. My old project was running smoothly on Oculus Quest without any issue.
After reworking everything to work without any dedicated SDK and installing the proper packages (WaveXR, XR Plug-in Management) I tried to build on Vive Focus 3.

The result was that the build was successful without any error. The unity logo started correctly and then I could see a single frame of my application before having a black screen and a lot of perfomances issues (I could hardly exit to go back to the menu). The app would generaly quit after 5 to 10 seconds to go back to the HTC menu (sometimes the audio of the app would stay).

I tried many things and the resolution was actually super simple. On Oculus project it is required to go with Anti-Aliasing x4. On HTC Vive Focus 3 it seems that the Anti-Aliasing is simply not supported at all.
So I just went into the URP settings and disable the anti-aliasing.

Everything was done using :

- Unity 2019.4.14f1

- Universal RP 7.5.1 (and 7.5.3)

- XR Plugin Management 3.2.16

- Vive Wave XR Plugin 4.1.1 (and 1.0.1)

 

I suggest that you add a critial error before any build to inform the user that Anti-aliasing is done directly by the SDK and cannot be added in the URP.

Unity always display a warning when using Anti-aliasing with an Android platform. For Oculus Quest 1 and 2 and Pico 3 neo, Anti-aliasing is recommanded in build.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...