Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Issues importing SDK from scoped registries


Lusther
 Share

Recommended Posts

Hello,

 I'm trying to import the hand tracking SDK on the latest LTS version of Unity (2020.3.20f1) by adding the scoped registries following this guide instructions (https://hub.vive.com/storage/tracking/unity/setup.html)

I filled in the following settings

image.png.30c1c2c653266a8809f727c92ebbfc88.png

Unfortunately it doesn't seem to work and I'm getting errors from the unity console.

image.thumb.png.547d2351363b60d4c51c6e904653c5f4.png

Are those registries still working ? Is there any way to make it work ? (I tried installing the package manually but the link I found to download the SDK was also a 502 error (link : https://developer.vive.com/resources/vive-sense/sdk/vive-hand-tracking-sdk/100/))

Thanks in advance for any help provided

Link to comment
Share on other sites

Thanks for the answer, I just installed it following the guide. 

Just one quick note, I tried following the Basic Usage guide but i couldn't found the skeleton model at their proper place (https://hub.vive.com/storage/tracking/unity/usage.html#draw-detected-hands-as-skeletons). With Unity, I found it under the following path : "Packages/com.htc.upm.vivehandtracking/Runtime/Prefab/RightHandRenderer.prefab" (instead of "Assets\ViveHandTracking\Prefab")
I'm not sure if it's a mistake of the documentation or a problem of installation on my side.

Link to comment
Share on other sites

Hi @Lusther

Good to know the install succeeded.

As for the prefab location, the document was written for the old unitypackage plugin. The package installed from scoped registry are indeed having different paths. You can just replace “Assets/ViveHandTracking" by "Packages/com.htc.upm.vivehandtracking/Runtime".

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...