Jump to content

My experience with the Vive Cosmos Elite.


Recommended Posts

For preface, this is a negative review of the Vive Cosmos Elite headset, firmware updates and Vive's means of "repairing" base stations based on my personal experiences.

I purchased an HTC Vive Cosmos Elite headset and accompanying accessories in October of 2020 as a birthday present to myselfSet up and install is fairly straight forward. After it's all up and running everything seems to be working perfectly and I greatly enjoy my experience.

That was until January of 2021.

I have no idea what caused it but I suddenly began receiving an error from my Vive Console, "Plug into a USB to a 3.0 or higher then restart the headset" accompanied by suddenly having no mic input. I find this strange considering my laptop has nothing but 3.1 USB ports. I never changed which port my headset was plugged into. This error seemingly came out of nowhere. (Keep in mind I still have this error pop up every single time I use my headset. It has never gone away.)

I dug further into this error and figured out that I am having a USB driver error and it is essentially telling me that I don't have enough USB endpoints/resources to complete some function. I'm not terribly tech savvy but I did everything in my power to understand and fix this issue, however I was unfortunately never able to fix it. I do not recall if my laptop had an update that altered my drivers, but even if it had, I tried rolling-back and updating my drivers repeatedly with no luck.

I'm annoyed, but there's nothing I can do about it, so I just deal with it. I don't use the mic anymore (because I literally can't). After who knows how long I began to run into more issues. This time I have no audio output from the built-in headphones. I don't receive any new errors, it seemingly happens for no reason. I check to be sure the output device is in fact set to the HTC Vive Cosmos Elite headset, and even if it is, there is still no output. I have to unplug then re-plug-in the headset 2-5 times every single time I start it up to receive audio output. I don't know what's causing this. I rolled back and updated my audio drivers to attempt to fix this with yet again no change. I still have no explanation for why it does this.

Frustrating, but manageable. However eventually I yet again ran into more problems. This is where everything began to spiral into a torturous carousel.

Not only is the built in mic entirely unfunctional and I now have to repeatedly un-plug and plug-in my headset to receive any audio output, now I am starting to have momentary grey-outs after 15-30 minutes of play. I am even more frustrated, but I have enough patience to wait it out until my display comes back. Not too long after this, my right controller now isn't properly tracking and will drift off into the abyss. Great, absolutely fantastic. After dealing with dodgy tracking for a hot while I finally get a notification telling me I need to update one of my base stations (I have two base stations. One of them has never encountered any issues). I do so then notice a red blinking light coming from the now updated base station. I receive an error telling me that my base station has "encountered an internal hardware issue". I didn't know what to do about this and at the time I did not check my warranty status, so instead of sending it to be repaired under warranty I simply ordered a replacement.

July of 2021 I order the replacement and promptly after switch the broken one out.  The replacement works perfectly fine. I have decent tracking, no mic input, temperamental audio output and occasional grey-outs. Annoying but I'll tolerate it, I spent a lot of money on this after all, I may as well make the best out of it.

Eventually I get a notification telling me that there is a base station update available. So, I update the base station firmware. Uh-oh, suddenly the replacement base station that I exclusively purchased to replace the one that received "an internal hardware issue" has now encountered "an internal hardware issue" immediately after the update. I do a little research about this and why it was happening and figure out that I wasn't the only one having this issue. Evidently, there was in fact absolutely nothing wrong with my base station, it was just Vive's update that apparently constantly breaks people's base stations. I look at reviews and pleas for help from multiple people online to see if there is actually a solution to this problem. I read one forum post that explains that Vive sent them instructions to go into their own computer files in order to fix the base station. "No way", I think to myself. That sounds absurd.

I find no means to fix my base station online so on May 11, 2022 I finally contact HTC customer service for help. I explain my situation and am told that my warranty for the replacement base station is still valid. I pack up my broken base station and send it off to be repaired. I receive a new base station on May 24th. I plug it in and test it out and it works perfectly! I play for a little bit then finally decide to hop off for the night. I don't touch anything. I don't get an update notification, I don't restart anything, I simply close out of Steam VR and the Vive Console.

I get up to play again the next day and I noticed a clicking noise coming from inside the base station. The base station had a blue light and was making a clicking noise. I contact customer support again and explain this strange issue. They tell me that we can, "try to do a firmware rescue to try to make the device react". No idea what that implies, but sure, I'll try anything at this point. They forward me a .pdf file labeled "Firmware Rescue". I look at the instructions and I discover that the forum user was in fact telling the truth. I would have to dig into my own data files and repair the base station myself.

I follow the instructions to repair the base station. This does nothing. Customer service suggests I uninstall then reinstall Steam VR entirely before they resort to having me send the base station back. I follow the new .pdf document labeled "SteamVR Reinstallation" and... Nothing changes. I continue with the repair ticket to send the base station back. I suddenly remember that I still have the original base station that initially encountered the "internal hardware issue". I decide to try the Firmware Rescue on it and it works! Unfortunately, it no longer syncs with the other base station. I look up what to do if they cannot optical sync and the HTC support website tells me to use the sync cable that came with my headset.

My headset did not come with a sync cable. Not only that, there is no sync cable listed anywhere on Vive's accessory store. I get a notification that I need to update. I reluctantly do so, fully expecting to suddenly receive an error, which I do. I do the repair again with the same result: Seemingly operative yet unable to sync.

Finally, after three separate base stations malfunctioned and needed to be replaced, I receive base station #4 on June 26th.

I plug it in and I find that it won't sync with the original base station just like the original can't. Oh no, it tells me to update. It wont be able sync without the update, but updates tend to make them unusable. I wince and click update device.
...
Base station #4 ... Syncs. It's tracking. Fully up to date.
Even after the cursed updating it is functional.
Hallelujah.

The question is: Will it suddenly break itself after I try to play again?

Link to comment
Share on other sites

Some of the issues admittedly could have been caused by my own laptop, however there are many other issues with the headset, accessories and firmware that users should not have to encounter whatsoever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...