Jump to content

Focus 3 - linker error libopenxr_wave.so is not accessible


Recommended Posts

Hello, my OpenXR app on Focus 3 crashes on start-up due to the following linker error:

library "/vendor/app/openxr_runtime/lib/arm64/libopenxr_wave.so" ("/vendor/app/openxr_runtime/lib/arm64/libopenxr_wave.so") needed or dlopened by "/data/app/com.alvr.alxr_client-TmMRAcd2udgNGwvW9mmgTg==/lib/arm64/libopenxr_loader.so" is not accessible for the namespace: [name="sphal", ld_library_paths="", default_library_paths="/vendor/lib64:/vendor/lib64/hw", permitted_paths="/odm/lib64:/vendor/lib64:/system/vendor/lib64"]
Tue Jul 12 2022 23:57:45 GMT+0300 (Москва, стандартное время):error7230/5741 OpenXR-Loader
Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : RuntimeInterface::LoadRuntime skipping manifest file , failed to load with message "dlopen failed: library "/vendor/app/openxr_runtime/lib/arm64/libopenxr_wave.so" needed or dlopened by "/data/app/com.alvr.alxr_client-TmMRAcd2udgNGwvW9mmgTg==/lib/arm64/libopenxr_loader.so" is not accessible for the namespace "classloader-namespace""<br>

hello_xr (both gles & vulkan versions) runs fine, I assume the reason why this happens with my app is due to my app setting the minimum-sdk api level to greater than 24/25 according to this? the problem seems to be that the path /vendor/app/openxr_runtime/* is not in the permitted_paths.

I really can't make my app go lower than API level 26 without doing major changes to my code base.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...