Jump to content

Cannot launch *just this month's* Viveport subscription games


Recommended Posts


All of this month's Viveport subscription apps will not launch. Everything else stills works perfectly. Anyone else experiencing subscription related issue? 


In more detail:

Been enjoying Vive for a month or so, without a hitch so far. First month's trial viveport selection was great. All 5 games/apps ran flawlessly.


Yesterday it was time to select new titles for the first time. Selected these four so far: Twisted Arrow, Front Defense, Knockout League, Ghost Town Mine Ride & Shootin' Gallery.


Whenever I try to launch any of these four titles, and just these four titles, I get the app's exe name with (unresponsive) in front of it for a second, then back to steam home.


Logically, there is an issue with the subscription itself since it's the only common denominator for these four games. All other apps and games work fine, launched either through vive or through steam.


What I've tried so far: rebooting headset, rebooting machine, uninstalling and reinstalling vive, launching through steam, launching the app's exe directly, uninstalling and reinstalling these games.


I'm on Win7 x64, i7-2600k, 16GB, Titan X.

Any help will be appreciated.


Ori H


Update: spoke with Vive US support. This issue might be location related since I'm in Tel Aviv and not the US. They took forever to answer and couldn't or wouldn't help any further and eventually directed me to Vive EU support, which are offline at the moment.

This might mean that Geoip is used to block non US Vive subscribers, which would make the Viveport subscription completely useless to me. If so, it would have been nice to know this in advance. Also, an error message instead of just quitting the app would have been great. Might have saved some hair pulling.


I had to choose US during signup, it wouldn't let me continue with any other choice on the list. I also mentioned this to a vive rep. on a previous support chat, after being unable to redeem the EverestVR and Richie's Plank Experience codes that came with the Vive kit. He said it was OK and just redeemed them for me. They installed and worked perfectly, like all other vive and steam apps so far.


I truly hope I'll be able to enjoy the viveport subscription despite not being US or EU based.

Will update this after speaking with EU vive support. Probably just talking to myself here anyway, but hey, they say writing issues up is therapeutic.

Link to comment
Share on other sites

Hey  - you're not talking to yourself. :)


We're going to investigate this. What version of Viveport are you using? (Check under the 'About' section of 'Settings'; it should be r1076).


Along with that, can you send me a private message with the email you used to sign up? That'll help us figure this out.

Link to comment
Share on other sites

Hey again . We're taking a look at your account, but if your previous month worked, I think it may be a local issue potentially. I know you've done a bunch of troubleshooting already, but let me double check a few things.


Where are you launching your apps from? There are a few options: within the Viveport desktop client (in Windows); within Steam Home (in VR); within Vive (in VR). If any of those options haven't been tried, can you?


I also want to make sure you haven't got more than one account registered, which is possible to do. We can see your subscription titles on your account, but it's possible you're logged in with another account. To check that, in the Viveport client click on your avatar (top right) and log out, then exit the client and re-launch - you should get prompted to login. When you do that, if you've ever logged in using another account (for example, made with a social login) then you'll see that. Select the one associated with your email.


Get back to me and we'll keep troubleshooting.

Link to comment
Share on other sites

Hi again,

Tried launching these apps from the viveport client and from steam. Now also tried from within VR, through steam and vive libraries. Haven't thought of that before, but sadly it's the same result.


I've only ever registered or logged in with this account, never on another computer, never through a social plugin (I don't use the log in with google feature on general principle). Logged out out and back in again just to make sure, there's only one account.


Purchased a new game on steam and it works just fine. I suspect this is viveport subscription related. Perhaps you might dig up further insights.



Link to comment
Share on other sites

Update & workaround: Just got an email back from vive support. According to the logs I sent, it seems that the anti virus is the culprit. I'm using Kaspersky Anti Virus. When I turned it off I could run at least one game so far. I assume the rest will work as well.

Did not suspect Kaspersky for a second, as it's a very popular, almost ubiquitous, anti virus. I assumed it would have been tackled in QA or reported by a user by now. Odd that the first (trial) month's titles worked just fine.
In any case, I'm glad this is issue documented here so that other users facing it will have an easier time troubleshooting. The chat support person first told me that this is a regional thing.

Hopefully this compatibility issue will be addressed in a future viveport update, as users cannot be reasonably expected to turn off their anti virus whenever they want to play.


In the meantime, I've asked Viveport support if there is some exe or process that I can add to the whitelist in kaspersky to avoid having to turn it off completely.


 I could still launch all previous viveport titles, it was just these four. Something in the viveport launcher or subscription verification must be clashing with Kaspersky.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...