Jump to content

using steam menu causes all sorts of issues


Recommended Posts

Id saying atleast 80% of the time if I press the menu button (the one under the trackpad) my display starts juddering and then goes blue.  If you look at the Steam VR icon both controllers start flashing and the two base stations go grey.  20-30 seconds later the base stations show green again (they don't physically goto sleep but steamvr no longer sees them) but the two controllers continue to flash and the vive screen remains blue.

To correct the issue, you have to right click on the controllers and choose power down.  Once both are powered down the headset will then respond again (just with no controllers).  You then have to  repair the controllers (simply powering them back up doesn't work, you have to pair them).


Any ideas (baring usual uninstall, reinstall lark)?

Link to comment
Share on other sites


I'll probably have to recommend some sort of reinstall procedure eventually anyways, but I'm curious how long this has been going on? Was it always a problem or did it emerge recently? Both controllers or just one?

Thank you,

-John C

Link to comment
Share on other sites

Also, if you have a sim racing wheel or a flight stick with a throttle control, try unplugging it or powering it down when using the Vive controllers to see if that fixes the issue. On some setup, a throttle control will cause the Vive controllers to act strangely.

Regards: Jack

Link to comment
Share on other sites

It didn't used to do this, I never had a problem loading the menu.  Then I would notice sometimes I would load the menu and the laser pointer would come out of the controller and shoot out past the virtual menu and the screen would freeze.  More recently though this display started to go out of sync.


I am trying to work out if it is certain games that cause it to happen, startrek bridge crew might be a perfect example if you want to try it and see if it does it for you also.


ps I donmt have any other game/joypads connected.


I will test now and see if it only happens on one controller or both.

Link to comment
Share on other sites

OK I have just tested it.  Loaded up steam, no game just Steam VR Home


Soon as I pressed the menu button, though the screen is still tracking fine (I can put my headset on and look around the VR home) both controllers are currently flashing in steamvr.  If I mouse over them it says

"The controller is connected but not tracking, make sure it can see a base station".


Right clicked on the controllers and powered down


Just tried the other controller, same again, this time I was watching steamvr software and each basestation briefly went grey (both stations remained powered up) and then they went green again and the controller icons both flash.


Just loaded room setup and one of the controllers came straight away back online, the other needed to be paired again.


I am going to rerun the room setup again, as I just looked in Room overview and notice the basestations aren't looking perfectly at each other (don't know if that makes a different but can rule it out atleast) thats based on the narrow beam you can see on the overview?.


Also trying steamvr beta to test aswell.




Link to comment
Share on other sites

I assume the controllers are charged and such? Also, have you tried it when they're plugged in?

Good idea on trying SteamVR beta. I wouldn't worry about the base stations too much. They don't have to be -exactly- point at each other, just within a reasonable FOV of each other.

Can you think of anything that might have changed around the time when they started acting up?


-John C

Link to comment
Share on other sites

Need to do a bit more testing with this, got it working then managed to stop it working again.  It maybe caused by a conflicted of software between steamvr and steamvr beta (if you switch between the two).  I will try and replicate again and confirm for sure.


He are the steps I just did

1. Opt into SteamVR Beta - Fault Still exists

2. Return back to Normal SteamVR - Fault Still exists

3. Uninstall SteamVR + Delete steamvr folder (after uninstall the folder still remained, with several log, cache and even exe files mainly relating to Bluetooth).  I had to unplug the headset to delete the folder.

4. Restart PC

5. Plug Headset back in and launch steam

6. Accept prompt to install steamVR

7. SteamVR - Problem no longer exists

8. Update to SteamVR Beta - Fault comes back

9. Return to normal steamVR - fault still exists


Need to run through all steps again and see if It replicates.


Link to comment
Share on other sites

  • 10 months later...

This issue is back again, I thought it had gone (maybe had been fixed in newer version of viveport or steamvr).

As soon as you open the menu, both controllers start flashing green and both basestations show grey (within SteamVR). Wait 30 seconds and the basestations go back to solid green. Only way to get controllers working again is to right click them in SteamVR and choose disconnect and then pair them again.

 Is there anything I can do to maybe output whats happening to a debug log which I can submit for investigation?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...