Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Focus Controller Firmware Update Fails


cimcpherson
 Share

Recommended Posts

Hi, I just recieved my Focus development kit, and following the first charge of the headset I tried it on. The controller paired fine initially using the provided batteries, but now whenever I boot the headset it tries to install a firmware update to the controller. Every time, though, the update fails because the controller is low on battery. It will go through 3 or 4 loops of "Updating", then "Low Battery", before showing the dialog to long-press the home button to pair the controller. After this point the controller won't pair and I have to restart the headset. 

 

I have changed the controller's batteries twice with brand new ones, and it still comes up with the "Low Battery" error. Apologies if this has come up before, I've tried searching the forum but cannot see anyone else having this problem.

 

Edit: If it helps, the controller status light is constantly a solid white, and won't turn off even after a number of hours

 

Edit 2: I've now had an error message pop up saying "ControllerScanner has stopped unexpectedly" after the screen goes black for 3 seconds. Still, the controller wont pair and there's nothing I can do but power off the headset.

Link to comment
Share on other sites

Internally the issue is under verifying which indicates there is progress.

However it takes more time for cross checking and verification since this happens occasionally during FOTA mostly for external developers.

I've asked the quick recovery method but looks it's a low-level tools which not proper for releasing.

I'll keep you update once more information has confirmed.

Thanks.

Link to comment
Share on other sites

 We have fix for this issue and under stress testing however I don't receive exact release time for you since the FW update require through FOTA.

After some discussion to support you to recover the blocking situation, it's better to return your controller to HTC via the channel or contact local support team to send you a new controller for replacement.

Sorry I don't know where you locate and who you contacted before for development.

Maybe  could help you if you're in US region.

 

 

 

 

Link to comment
Share on other sites

  • 3 months later...

Here is the description to clarify if you encounter controller failure issue during FOTA.

 

NOTE: Please don't remove batteries during FOTA.

 

Before update controller firmware, controller will enter DFU mode (download mode). Only if it is updated successfully, it will self-reboot to normal mode again.

When controller enter DFU mode, the led will show white light constantly.

 

SOP:

  1. Check the LED state.
  2. Whether the LED is showing white light constantly or not.
  3. if it is updated successfully, it will self-reboot to normal mode again.
  4. If it still keeps white solid light for a long time, maybe It’s the FOTA failure. 
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...