Jump to content
Limited Staff Responses: 4/2 - 4/5 ×

New Vive Pro: potential link box USB problems, error 108


Recommended Posts

Okay guys, I figured out what the problem was: the link box was broken. Here's how I know for sure.


I went to the store and tested my link box and Vive Pro on their working system. We uninstalled the drivers before connecting my hardware, and their system installed the drivers the wrong way, just like on my system.


We then uninstalled the drivers again and connected my cables, my Vive Pro, but their link box, and behold: everything installed correctly. We solved the problem by giving me a different link box. It now works on my home system and saw the Steam VR room for the first time! :)


So before you troubleshoot as much as I do, make sure the hardware is working! Here's how you can tell your link box is working as it should. When Windows starts installing the drivers, it should install (and finish) the following set of drivers:

  • VIVE Pro
  • VIVE Pro Multimedia Audio
  • Watchman Dongle
  • LHR
  • VIVE Pro Multimedia Camera
  • Watchman Dongle (2nd time)

When you have a broken link box, Windows will only install 1 driver:

  • VIVE Pro Multimedia Audio

Everything else just didn't install.


This solves it! I hope all my research will end up useful for others with similar problems. Thanks for chiming in, those who did.



Link to comment
Share on other sites

  • 2 months later...

I have exactly the same problems as in the first posting.
but my htc vive drivers are almost all installed. only the bluetooth driver is not properly installed in the device manager. also my camera does not work.

my setting:
vive pro
msi 1080
asus ranger viii (usb 3.1 I disabled because it did not work with this)
intel 6700k

But I have observed that the camera has ever worked and do not believe in a broken linkbox.

anyone else have an idea?

Link to comment
Share on other sites

If your running on windows 10 the camera access is most likely disabled in the privacy settings in windows.

Click start, settings, privacy then camera access. make sure apps can access the camera.

As for everything but bluetooth greyed out I am beginning to stspect its steam VR that is just not showing the info.


Link to comment
Share on other sites

thanks, that was not the problem for me. I found that the camera works with 30hz. only with 60hz I have the problems described. whether usb3.0 or 3.1.
Now I can use the camera but bluetooth still makes problems, because the driver can not install. I have deactivated it now because I do not need it.

Link to comment
Share on other sites

  • 2 months later...

Hi Hammey,

At the time, I managed to solve my problem by troubleshooting at the store. If they have a demo kit running, you can see if it works on their pc. If they don't have one, try to convince them to swap units. Maybe point them to this thread? Good luck.

Link to comment
Share on other sites

  • 5 months later...


If I've paid hundreds of dollars for a system that requires me to erase and reinstall my operating system and all software it relates too, it might as well ask me to burn my PC and buy a new one.

Trash, worthless ripoff.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...