Jump to content

New Vive Pro: potential link box USB problems, error 108


flibble
 Share

Recommended Posts

So 8 hours into troubleshooting on my own I've tried every suggestion I could find, but none of them seem to work. I've tried unplugging and replugging everything into every USB port, 2.0 and 3.0, reinstalling SteamVR, installing SteamVR beta, powercycling, rebooting, repeat all ad nausum.

 

Some specs:

  • Windows 10 v1803 64
  • ASUS Z-370-P motherboard
  • Intel i7 8700K processor
  • Aorus Geforce 1080Ti
  • USB xHCI controller on motherboard

Some random info:

  • Usually when I plug in the link box, Windows does install drivers and it tells me it's finished doing that correctly.
  • The Vive Pro headset has a red light
  • SteamVR always gives the 108 error message
  • Unplugged every other USB device to reduce possibility of interference (apart from keyboard and mouse)
  • Tried installing viveport & steamvr and connecting it to other (older) PC with a clean install of Windows, exactly the same story
  • When I was fiddling with direct mode, and about to uninstall the drivers using USBDeview, I noticed the light turned green, and remained green, even as I had uninstalled the drivers (!). SteamVR still didn't recognize the device, but it did start displaying my desktop on the Vive, and some sound came through the headset, that's how I noticed it started "working". Rebooted SteamVR and it stopped working again.

 

USBDeview shows the following:

I would like to know what USBDeview is supposed to look like in a working scenario and how it differs from my broken case.

Windows device viewer shows:
Is it normal that it shows a number of "generic superspeed" entries? Why doesn't each entry have a more clear description?

 

SteamVR usb overview shows:

I've never seen any of the other options activated.

 

Does anyone have any suggestions left? I'm at my wits end by now.

 

Link to comment
Share on other sites

Hi Mroj2162,

Thanks for your reply. I don't doubt that it worked for you, but I'm gonna have to keep that suggestion in my backpocket as an absolute last resort. I estimate it would take me 10+ hours to reinstall Windows with all the applications I have. Also, I had my old computer at hand on which I did a fresh Windows 10 install a few weeks ago, and I had exactly the same results on that one.

 

I talked to the store I bought the Vive Pro from today, and they suggested I use Snappy Driver Installer to check if there aren't any hidden upgrades I could potentially do on my USB drivers that Windows doesn't show. I'll be trying that tonight.

 

Would you be willing to give me some screenshots of your hardware mgmt - USB overview, the SteamVR USB overview, so I know what kind of situation I'm targetting.

Link to comment
Share on other sites

Okay, so further steps I've undertaken, none of which have resulted in a fix.

  • Flashed BIOS
  • Updated Motherboard chipset
  • Used Snappy Driver Installer to hunt down any drivers that might need updating
  • Bought and installed PCI-E card with 3.0 USB ports

The store I bought the unit from has a demo unit, and I've taken some pictures from their setup, to have something to compare all of this too. Theirs works. Differences I've noticed in their setup are for example in the report overview. The screenshot below shows their report vs mine. I remember from the USBDeview support page you're supposed to uninstall devices 0BB4 and 28DE, but I never could find the 28DE drivers on my system, which is part of the problem I expect. On my system, he only installs (part of) the 0BB4 drivers and not the 28DE ones. See screenshot.

 

Another difference I've noticed is in the Devices tab in the report. Mine is just blank, it doesn't show any info. And when I copy that blank information to the clipboard, I notice that the Devices tag is blank. It differes from their system. See the screenshot below.

 

Another difference is in the USB settings view. Theirs has slightly more info in the description.

 

 

 

So..... what does any of this mean? Is it a driver install issue? How does the driver install work? I'm not an expert on the subject. Are the drivers downloaded from the link box, telling Windows how it wants to be installed? If so, does the link box need a firmware update? Would it be helpful to receive a driver download package from Valve or HTC?

 

Hope all of this info ends up being useful. I'll keep on fiddling and adding any findings...

 

 

Link to comment
Share on other sites

So...

Further research yields the following info: the Oculus compatibility check tool also finds some USB problems, as demonstrated in the screenshot below.

 

Now I know I have a Vive Pro, and this may not be entirely relevant, but I did learn that there seem to be problems with ASUS motherboards, which I have (Z370-P), because they might have ASMedia USB controllers (which I don't have). Apperantly both Vive and Oculus prefer Fresco USB controllers. The warning from this tool may because of the PCI-E card I just bought, or maybe because of motherboard. I don't know for sure and I'm too tired to open my case and unplug the PCI card. This is the support page I got this info from.

 

I tried download the Intel driver and support assistant installer to check if my system didn't need any kind of weird missing updates, but it didn't find anything.

 

The VIA USB 3.0 error message did lead me to some Microsoft support page, suggesting to use the Windows DISM program (Deployment Image Servicing and Management Tool) to check if there's some kind of problem with Windows, but that also hasn't yielded anything worthwhile.

 

This reddit thread suggests further info on compatiblity issues with specific USB controllers and although it's also for Oculus, it may be relevant for the Vive Pro since they recommend the Inatec PCI-E USB card specifically, and as far as I understand, that's a Fresco controller card as well.

Link to comment
Share on other sites

I'm having a VERY similar issue since I got my vive pro yesterday. Would it be possible to get those instructions PMed to me as well?

 

My Windows install is in the middle of a referesh as I can get my original vive to work but not the vive pro.

 

I'm keen to get it working asap

 

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...