Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

headset has no display


weirdguy

Recommended Posts

my headset has no display except on occasion when an image flicks on for half a second then off for 2 seconds then on off on off on off and so on, also whenever I move the headset the light on the side turns red, any help would be much appreciated. ps what the hell does the button on the side by the light do, I cant find anything about it anywhere, the lack of documentation on the headset is a little surprising considering the cost of the product

Link to comment
Share on other sites

Hi . Take a look at the headset section of the SteamVR support pages. If you've got a red LED light, it's likely to be a cable or driver error. The support pages linked can give you some troubleshooting steps.

 

If those don't help, I'd suggest you reach out to Customer Care for more direct help. If you're in the US, the link's in my sig (if you're elsewhere, you can change your region on the Customer Care page).

Link to comment
Share on other sites

seems it was the link box so it has been sent off for repair, brand new out of the box and its faulty, also the headset stopped powering on so its also been sent off for repair, great experiance total let down. no answer as to what the button on the side of the headset does?, why its not written/explaind is beyond me

Link to comment
Share on other sites

Hey , you're right, the use of the button on the left isn't very well documented. It's supposed to work the same as the 'system' button on the Vive controllers.

 

I'm sorry you've had these issues. Just to confirm, you've now got both the link box and the headset/HMD in for repairs?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...