Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

TextureHasUnsupportedFormat Error


arupmassmotion
 Share

Recommended Posts

I'm using OpenVR to add support for the Vive to my app. It was working fine the last time I tried it 2 months ago. I just tried it again and it is giving me the "TextureUsesUnsupportedFormat" error when I try to call "openvr::VRCompositor()->Submit( eEye, &eyeTexture );" The code and headset has not been changed in the last two months and everything was working perfectly then so I am confident in my code correctness.

The only thing that did change was a SteamVR update. Could this error have been caused by the SteamVR update and is there a record of such errors happening before or how to resolve them?

 

Link to comment
Share on other sites

@arupmassmotion - The SteamVR/OpenVR SDK is pretty fluid in the last few months due to Index's release. As it's a Valve managed SDK - I'd recommend posting a detailed issue report in the "Issues" section of the OpenVR Github and x-posting to Valve's SteamVR discussion board.

That said, I'm a little confused by this report - it sounds like the runtime updated but not the SDK/plugin and you're getting an engine error rather than a runtime error.

The return code for that error is copied below - it's referring to the assets in your scene - it may be that you now have an asset that's incompatible rather than being due to a change in the SteamVR SDK/runtime.

- TextureUsesUnsupportedFormat (scene textures must be compatible with DXGI sharing rules - e.g. uncompressed, no mips, etc.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...