Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Theater mode not working


Fduenn

Recommended Posts

Hello all,

 

I've tried searching for this but nothing, so here goes... Theater mode doesn't work, here's what happens.

 

1. In the headset I go through Steam, select the non-VR game I want to play, and pull the trigger on the "play in theater mode" button. .

2. Nothing happens; the view doesn't change from the menu selection screen but I hear the game playing

3. If I take off the headset or check the desktop through the Vive, The game is running on the desktop but not in the theater mode--I've never seen the environment as it shows up on youtube videos.

Any thoughts? games "work" if I just launch them through the desktop or through the virtual desktop app but that's far from ideal...

 

Cheers!

Fred

Link to comment
Share on other sites

Hey , as I understand it, theater mode may not work with all games - can you let me know which ones you're trying?

 

Also, can you confirm that when you launch the same game through Steam, while SteamVR is running, it does launch in theater mode? If it's only the in-VR shortcut that's not working, at least you've got options!

 

You've almost certainly checked this, but make sure for whatever game you're running, under the Properties in Steam, you have 'Use Desktop Game Theatre While SteamVR is Active' checked.

 

One final alternative - I've seen several people recommend BigScreen, which is in Beta (and free) on Steam. Might be an option. Let me know how you get on.

Link to comment
Share on other sites

Hi 

 

Yup, all the games have the box checked for running the game in theater mode if VR is active. So far I've tried Rimworld, FTL, Bit Trip Fate, Half-life 'a place in the west'. I've tried in windowed mode, full screen mode, anything I can think of.

 

To clarify: if I run a game just from Steam but not through VR, it does NOT run in theater mode. It pops up a warning that it'll open up on my desktop as well as SteamVR, but then runs on my desktop as if VR is off, and through VR I only see the usual opening environment of my choice (Bespin Catwalk, of course).

 

I'll probably try BigScreen next, but I'm worried about the lag I've found playing through the Virtual Desktop app... 

 

Thanks for your help,

Fred

Link to comment
Share on other sites

Hi , sorry to be a bit slow in responding.

 

A few suggestions from our care team - three separate here:

 

- Run Steam as Admin

- Open the game normally (not in Theater/VR) and ensure the game is set to Fullscreen (not borderless windowed, or similar).


- Opt-in to the latest version of SteamVR Beta, which may help.

 

- Manually force the game into Theater Mode. Right click the game from the Steam library, select Properties. Look for the "Launch Options" button and click it. Put "-vr2dgames" in that line (no quotes).

 

Ultimately, I'm afraid we (HTC) aren't responsible for desktop theater, so you may have better luck over at the Steam forums. :(

Link to comment
Share on other sites

  • 7 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...