Jump to content

DllNotFoundException: aristo_interface


Recommended Posts

To run inside Unity Editor, please make sure:

  1. Your are using 64bit Unity Editor.
  2. Make sure OpenVR is selected and loaded as VR/XR device.

got same on unity 2018 

Unity 2019.4.15f1 (64-bit)

and Unity 2020.1.12f1 (64-bit)

any idea is welcome thank's 


Link to comment
Share on other sites

Hi @kilik

Here are some some points I can think of to check.

  1. You are using the latest 0.9.4 version.
  2. You are running Windows Unity Editor. Linux/Max is not supported.
  3. You can try to run the pre-built windows sample and see if that can work.


Link to comment
Share on other sites

yes last version

it's windows pro maybie 

same on build 


so i have try on another computer and it's work with some crash on start  

but i have gray image on vive when camera is active so i see hand only on editor

any option about this ? 




Link to comment
Share on other sites

Hi @kilik

For first question, another thing I can think of is to install MSVC 2015 update 3 runtime on your PC. The dll not found problem might be caused by failure to load dependency dll.

For second question, if your image is not correct, then it's possible hand detection fails. If you are hand in editor, is that using EditorEngine (which generates fake hand data)? For camera problem, I would suggest to follow steps here: https://hub.vive.com/storage/tracking/misc/steamvr.html

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...