Jump to content

Suddenly NO DISPLAY!?! - Vive Cosmos Elite


Recommended Posts

I've had the Vive Cosmos Elite (using Wireless Adapter) since August and everything was running fine until 2 days ago. Suddenly there is NO IMAGE on the Headset Display! Nothing.

Desktop "VR View" still displays perfectly, tracking all movement on the computer monitor. Just NOT the headset.

-SteamVR reports no error.
-The Vive Wireless Software shows no error.  
-The LED light on the Headset is showing Green. (Sometimes Red, but almost always solid Green)
-I have uninstalled/reinstalled SteamVR (manually deleted all setting files and content of SteamVR folder).
-I have uninstalled/reinstalled Vive Wireless Software.
-I have reset all settings on Vive Console Software.
-Even tried switching to the Vive Beta Program.

My Specs:
Mobo: Z370 Aorus Gaming 5
CPU: Intel Core i7 8700
GPU: GeForce RTX 3080 Asus Tuf Gaming

I am desperate here. Spent two full days trying to get this working. I bought this in August and have been waiting for some time off of work to really enjoy it. Now I am currently on my Christmas vacation and I can't get it to work. I just splurged for a 3080 RTX and I have to go back to work in a few days! This was my one chance to just play in VR without distractions. Please help! Running out of time. Thank you!

Note: I -did- submit a Report via the Vive Console but I'm freaking out! I never received an automated confirmation email.

**Trace Number: 20201222012515 **

Link to comment
Share on other sites

Thank you so much for replying. As you can tell from my Original Post, I'm dying over here!

So, yes. I reseated all cables. I even removed the Wireless Adapter and its related cables completely and tested everything out with the original Wired/Cabled connection to the PC (the HDMI/DP and Power cables). I even reinstalled Viveport and ran Device Setup and it correctly identified my DisplayPort and USB connections. But still, no display on the actual Headset. Again, SteamVR's VR View shows everything tracking and displaying normally.

Also, I've been using the original 21-Watt Battery that came with the Cosmos Adapter Kit. I also tested with the Official OG Vive Battery as well as a third party Anker PowerCore Speed 10000mAh Qualcomm Quick Charge 3.0 Power Bank.

Link to comment
Share on other sites

I don't know if it helps to mention this. But I actually upgraded from the Original Vive to the Vive Cosmos Elite. I guess that makes me a serious HTC "fan boy". People told me I was crazy to spend that much to make such a minor upgrade but staying untethered was -that- important to me. My YouTube Channel provides lots of video examples of why Wireless/Untethered is the -only- way to go! The OG Vive worked flawlessly with and without the Wireless Adapter and I thought the Cosmos would be the same.

Here is my YouTube channel with plenty of footage of me playing untethered in my (relatively) massive roomscale area: https://www.youtube.com/watch?v=arl9-ATAYq8&t=818s
Here is another: https://youtu.be/CJg3UXXN_HA
These videos are what I use to explain to people why it's worth it to spend the extra money and choose a high-end VR headset with Wireless capability. People are constantly messaging me at my channel asking me what VR solution is better and I honestly don't know what to tell them lately. Real true high end VR (Like the Cosmos) is amazing but it takes hard work and maintenance to get it working and constantly -keep- it up and running. The simple plug-and-play headsets out there (like Oculus Quest 2) are nowhere near capable of providing the graphic visual experience and accurate tracking that these high end headsets can provide. That said, all I know is that I am sitting here miserable, on my first break from work in a long time with no VR. @C.T.

Link to comment
Share on other sites

UPDATE: I haven't had much luck with HTC Support via email so today in desperation I hooked up my old Original Vive to the same PC and it works fine. So the OG Vive display works and my brand new Cosmos Elite display does not work. Any ideas? I have a $1000 piece of dead hardware here and I need some resolution.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...