Jump to content

No OpenCL device found.


Recommended Posts

Dear Support,

I am trying to get the eyetracking on my headset to work so we can continue with our research. 

My specs:

VR headset: Vive Pro Eye 

GPU: NVIDIA RTX 2080 Super  -> driver version:

IGPU: Intel UDH Graphics 630 -> driver version:

SRanipal version:

Steam VR version: 1.16.10


There is a " Vive Pro Eye Calibration Initialization Error Troubleshooting" page and I've tried everything there but nothing seems to work.


Hopefully you can help me resolve this problem quickly. I still have to build it into an application before the end of the month. 


The error I'm getting can be seen in the attached image. 


Thanks in advance!

Kind regards,



Link to comment
Share on other sites

further elaboration:

It seems that a lot of programms search for a Registry key path for OpenCL supposed to be under:


Both these keys are missing in my case. could this be the problem? 



I've tried to create the keys myself but they don't seam to resolve the problem.





Link to comment
Share on other sites

I think I'm on to something with the registry keys.

Changing the registry keys as followed actually changed the situation:



The thing is... it is no longer giving the "No OpenCL device found"  error but other than that it doesn't start at all anymore. it just gives a loading circle and then dissapears for good. Before changing the registry it would still say it was dorment in the windows thumbnail icons in the lower right corner of the screen. I've also changed the registry back and this results in the same errors as before so it's replicable by changing the registry keys as shown above. 

If anyone could share an image of how their registry looks at the provided paths, that would be awesome.



Link to comment
Share on other sites

Here are the log files. Hopefully you can help me.

PS. GPU caps viewer also shows that OpenCL is not supported. A colleague with exactly the same laptop does have it showing up in caps viewer. 

I've now also tried a fresh install with DDU for the GPU driver but this also doesn't work.

The regestry keys don't seem to fix anything and I'm starting to think that the GPU has hardware issues. Hopefully this is not the case.


How do I pm you? Not that I need to, but I don't seem to find a possibility to do so and you only get 3 posts a day on the forum.


SteamVR-2021-03-19-PM_01_14_01.txt ViveSR_Log.zip

Link to comment
Share on other sites

Apparantly the pm button wasn't there before because I wasn't logged in. I have spoken to NVIDIA and they came to the conclusion that it's a Hardware issue. Dell (the provider of the laptop) is coming next Tuesday to replace the GPU. I'll keep you posted if that resolves the problem. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...