Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Vive Input Utility not registering inputs


Recommended Posts

My company is using Unity 2020.2.7, with Unity's XR Interaction Toolkit/UnityXR.  When we tried to integrate Valve's OpenVR plugin to Unity we had the problem where the controllers gave no input.  This is apparently a known issue.  We then tried to integrate Vive Input Utility on top of this and had the same issue (controller tracks but no inputs).  We are currently using someone else's project that allows SteamVR to work and provide inputs, but again this doesn't work for the Vive Input Utility.  This means we are stuck in a situation where we can support the Vive through the SteamVR hack, but not the Vive Cosmos.

My question, therefore, is does anyone have a guide to how to integrate the Cosmos with Unity 2020.2.7?  The pinned discussion in this forum links to a dead page for the SteamVR plugin, and I assume it's the same one we tried.

Thanks and I appreciate the help,

-Bert

Link to comment
Share on other sites

@bert.haddad What is your project setup environment?

Unity: 2020.2.7

Which plugins you installed/imported? VIU? OpenVR plugin? SteamVR Unity plugin?

Did you try to play any VIU's example scene?

Could you also try to restart SteamVR?

Any log in console?

 

UPDATE:

I just tested Cosmos and I can get inputs successfully in 1.UGUI scene.

My project setup environment is Unity 2020.2.7, VIU v1.13.0-preview9(You can download from VIU github, develop branch) and SteamVR Plugin v2.7.3.

Link to comment
Share on other sites

OK, I got it working!  I had changed some of the SteamVR local bindings for my previous SteamVR fix, and that was overriding/breaking the Vive Bindings.  Once I nuked those it worked like a charm.  Thanks for the reply!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...