Jump to content

Dose Unity VIU's hand tracking supported to Focus3?


Recommended Posts

I,m trying to create a project that cross platform for vive focus 3 and oculus quest2 with unity.

Focus3 hand tracking worked on "VIVE Wave XR Plugin - Essence" demo, but not working at "9. Tracked Hand UGUI Interaction" from VIE's sample (but it worked on oculus quest2.)

so dose VIU's hand tracking supported to focus3?

or did i miss something that required?

These are my setting in the project.

2021-07-19_144140.png

2021-07-19_144211.png

2021-07-19_144320.png

Edited by 12345467860785678
Link to comment
Share on other sites

Hi @12345678912345678912345678 Which VIU version are you using?

Did you check Activate Wave Hand Tracking Submodule and Enable Wave Natural Hand in VRModuleSettings.asset file?

Which scene did you test on? 9. Tracked Hand UGUI Interaction?

Please provide the logs right before you launch the apk and until your scene is loaded?

Could you also share your apk for me to debug?

Link to comment
Share on other sites

Hi @chengnay

My VIU version is 1.13.2. and I have updated VIVE Wave XR Plugin to 4.1.0-preview.5.1 to make Wave be compatible with VIU. 

And I have checked the .asset file just like the picture in your previous reply.

The scene on which I am testing is the sample inside the VIU package named "9. Tracked Hand UGUI Interaction"

Sorry, but I have no idea where to retrieve the logs, Could you please tell me where it is?

And here is my apk file
https://drive.google.com/file/d/1HhUcQMwHxt6h_rocbLiIY5zEcOcK1feD/view?usp=sharing

Link to comment
Share on other sites

Hi @12345678912345678912345678,

You can manually record the log by using below command line,

> adb logcat > xxx.txt

Execute the above command right before you launch the apk, thanks!

 

UPDATE: I just tested your apk, it seems ok except that your right hand model did not appear and no pinch event.

Did you modify the "9. Tracked Hand UGUI Interaction" scene?

What is your Focus 3 rom version?

Link to comment
Share on other sites

Hello @@chengnay, I'm @12345678912345678912345678's friend. For some reason he could not reply so I'm here to do it for him. His reply is as follows:

It turns out that the reason why it didn't work is that the system needs some time to switch the operation mode from the controller to hand signs after I put down the controller, and I was too early to start testing with my hands. I just need to wait longer and it works very well. There's no problem anymore. Thanks for the supportive and helpful instructions! I really appreciate it!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...