Jump to content

HTC Vive Cosmos Adapter Problem


Recommended Posts


Hey all
I have tried everything from formatting the computer to updating the chipset, uninstalling usb drivers, graphics card drivers etc.
I have a laptop ASUS ASUS TUF Gaming A17 FA706IH-AU454, the laptop has no displayport input but it has USB-C Display.
Google worked until the day before yesterday, when while gaming the laptop turned off by itself. Since then, I get the message "Unsupported USB-C sound card" 



I bought a second adapter 1.4 because I thought it stopped working,
                           the two adapters in the picture 
Laptop has 1x USB 3.2 Type-C Gen2 (Power Delivery & DisplayPort 1.4 mit G-Sync)
I do not know what to do, everyone thanks for the help


Link to comment
Share on other sites

Are you able to access to this page and upload the screenshot here for reference?
Checked the laptop spec, the best GPU is 1660Ti with this series, may just be the baseline for recent VR devices. 
With the lack of the DP support from dGPU, some gaming laptops may not be suitable for VR. 


Link to comment
Share on other sites

  • 2 weeks later...

I've always used this adapter with all of my HMDs:


Unfortunately, the Pro 2 does not work with it only on my Laptop. So I found out that this works:


I hope this helps.

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...