Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

SRanipal is starting but getting disconnected within few seconds


Recommended Posts

Hello,

I have been using SRanipal eyetracker for the last 6 months and I am recently facing an issue. Whenever I try to start the SRanipal app using admin, it starts, but after 2-3 seconds it gets disconnected. I tried uninstalling-installing SRanipal for several times but I am having the same issue. I have tried updating Steam, Unity but nothing helps. I have another laptop, for which SRanipal is working just fine, it has same version of Steam and SRanipal. I also tried to reinstall Tobii VR02 Runtime and SRanipal together again and again but it is not working at all. When I open the SRanipal with admin access, I can see the robot's eyes are lit orange, hence I know it is working at that time. But after 2-3 seconds, I hear a attachment disconnect sound and I loose the eyetracking capabilities. Has anyone faced this issue? If you have solved this issue, please let me know about the steps.

Thank you very much!

Link to comment
Share on other sites

For our just recently acquired Vive Pro Eye I see very similar symptoms;

The eyes first light up in orange for a few seconds, but then turn black again. Occasionally (2 times so far), they will stay orange, but still the eye tracking does not work. The "about" dialog of SRanipal shows:

Runtime Version: 1.3.2.0
Runtime Type: Public
Eye Camera Version: 
Lip Camera Version: N/A

(I also have the face tracker; when I attach that, the face tracker lights up in orange, and the Lip Camera Version shows 50100. But the lip tracker works (tried in Face Gym). The eye tracker has not worked yet).

I hear some USB connect/disconnect sounds after I plug in the link box, and when I check the connected USB devices, the "EyeChip" pops up occasionally but never stays there very long. Sometimes, a message box will pop up saying "firmware updating device firmware is updating!!! Please wait for minutes and keep device power connected". But even after hours, there is no notice about any firmware update progress, success or failure.

I have tried it on two different PCs (one a bit older with a Xeon E5-1660 v4, and a Quadro P5000; and the other with a Core i9-11900K and an NVIDIA Geforce RTX 3090), and have played around with connecting the link box to various USB ports, but the behavior is always the same.

It only seems to concern the eye tracking, everything else is working as expected. I've exhausted all options I can think of (uninstalling and re-installing SteamVR, SRanipal..., trying different USB ports, trying a different PC, ...), what can I do?

Link to comment
Share on other sites

  • 8 months later...
  • 1 month later...

I had this problem, resolved:

There's a privacy/permission menu now inside SteamVR that needs to be activated. I don't think it's accessable on desktop; bring up your Steam dash in VR and click on the 'Vive Pro Eye' icon on the bottom to get to it. Then there's a button on the eye calibration menu that should take you there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...