Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

I cannot update my Vive Focus 3


Fabian Jäger
 Share

Recommended Posts

I have a problem with a Vive Focus 3 and a Vive Business batch file. After I received the Focus 3, I created a Batch-File and deployed it to the device. But since my Vive uses version  3.0.999.94, I cannot update the device via the Vive Business manager. It says "Waiting..." and nothing happens, which seems to be a know bug that was fixed in version 3.0.999.197 (

). The update button in the settings menu doesn't exists either, because the device is managed with the Vive Business manager. So the next step was a factory reset (i tried both, the menu entry in the settings and the Android Bootloader), but neither deletes the batch file from the system, so it gets reinstalled after reboot. This is the correct behaviour, since I enabled the setting in the batch file creator to store the batch file on the device (sorry, it is in german, but I hope you know what I mean):

image.thumb.png.91b01762e052f9f8590a778765179d91.png

Therefore, I created a new batch file with the settings to delete any existing batch files (sorry, it is in german....):

image.thumb.png.17652fdf97006ac1572de4672dc1cf4e.png

This batch got installed and I tried another factory reset, hoping that the old batch file got deleted from the device. But that didn't work either... Every time I reset, the old batch file gets reinstalled and I get to the same point, where I cannot install any system updates.

Is there any way to remove all batch files from the device? I tested the adb connection and it seems to work, so at least I see a change to get access to the device (file exchange via the windows explorer doesn't seem to work either, since there is another bug in the 3.0.999.94 that was fixed later).

Does anyone have an idea, what I can do from here?

 

image.png

Link to comment
Share on other sites

If you would factory reset your headset without the batch config apply, you should be able to get the Software update afterwards. 
Let me know if you find it otherwise. Thanks 

Link to comment
Share on other sites

We are having this same exact issue with our Vive Focus 3. I have tried to install a new batch configuration just like Fabian did, but after the factory reset, the old batch gets reinstalled.

This is likely because the firmware needs to be updated, however, both the headset and the Vive Manager app do not show any new firmware updates. Trying to update via the Vive Business Manager doesn't work either, as it stays stuck at "Waiting..." and doesn't do anything. Our headset is also on version 3.0.999.94.

We have also signed up for the Beta program, but there is no "Beta features" option at all, likely due to the inability to update the firmware.

EDIT: Additionally, factory reset without a batch config file does not work either, as it simply reinstalls the old one.

Edited by mikeb_8818
Link to comment
Share on other sites

10 hours ago, mikeb_8818 said:

We are having this same exact issue with our Vive Focus 3. I have tried to install a new batch configuration just like Fabian did, but after the factory reset, the old batch gets reinstalled.

This is likely because the firmware needs to be updated, however, both the headset and the Vive Manager app do not show any new firmware updates. Trying to update via the Vive Business Manager doesn't work either, as it stays stuck at "Waiting..." and doesn't do anything. Our headset is also on version 3.0.999.94.

We have also signed up for the Beta program, but there is no "Beta features" option at all, likely due to the inability to update the firmware.

EDIT: Additionally, factory reset without a batch config file does not work either, as it simply reinstalls the old one.

Sorry to hear that, but it does seem like you have this enabled when first enrolled into the config package

So, you will need to take extra step to delete the beta config package in this case. check below screenshot in the 2nd page of the config page, you will find it in the bottom.

It should get your device back to normal and receive update after.

image.png.3a63773e230ef8bdd24737aaadee071d.png

Link to comment
Share on other sites

Hey everyone,

I had the exact same issue which I managed to resolve.

Please try plugging in your Focus 3 devices and then restarting while connected to power. I've had luck resetting/restarting in this way to force the device to acknowledge the update—without it plugged into power it simply doesn't work as it should.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hi all,

I'm now having this issue too but it's unclear to me what the process to update firmware is.  How exactly are you supposed to update the firmware on a batch file managed HMD?  Are you supposed to create a new batch file and go through the SD card process again or is there a better way?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...