Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Vive Focus 3 in Unity will not show any controllers or hands


taa11
 Share

Recommended Posts

While developing in Unity, I believe I have all my settings correct, but when I go into Play mode or build a game, I do not get any controllers or hands of any type to show.

  • Headset software version 5.0.999.624
  • Unity Version 2020.39LTS
  • Headset Wave SDK version 5.0.2.014

I have downloaded the HelloVR from GitHub which the forum provided. I get display right away, but no working input ability. I am attaching pictures of my project and settings.

Could someone please offer help?

Unity game with no hands or controllers.png

Vive Packages Installed.png

Vive focus 3 in xr plugin management.png

project settings controls.png

project settings -open xr settings.png

Build settings in Android with Vive Focus 3.png

NVidia RTX 3080 set as processor.png

Link to comment
Share on other sites

Thank you for the help. I have downloaded and imported the SteamVR plugin. It will not show in Package manager though, once it is imported. Could this be something being blocked by our internal filter?

Link to comment
Share on other sites

I was able to get the controllers to show, but the camera breaks. Now the VR headset (Vive Focus 3) is looking out into the distance and the controllers are way out in space. You can not interact any longer with the scene.

Link to comment
Share on other sites

  • 2 weeks later...

Hi @taa11,

I would like to provide some assistance if you are still having an issue. I was informed that your environment is the following:

  1. Headset software version 5.0.999.624
  2. Unity Version 2020.39LTS
  3. Headset Wave SDK version 5.0.2.014

Have you tried comparing your project to the HandInput and ControllerInput sample scenes found in the VIVE Wave XR Plugin - Essence package? Have you tried updating to the latest version of the VIVE Wave XR Plugin? If you have already tried these troubleshooting steps, then I would ask if you could provide a sample project that reproduces the issue or provide some steps that would help me reproduce the issue in a sample project.

Link to comment
Share on other sites

Am I to understand, you would like me to backtrack, and go back to the older vive wave xr, even though the headset is slated for OpenXR? Would I have to start this in a new project, or add to my existing project, which already has the wave openXR android, and wave openXR windows packages.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...