Jump to content

(UNREAL ENGINE) Can't seem to get bluetooth inputs to register in a Vive Standalone Android application


Recommended Posts

Hi Vive devs,

Was wondering if anyone has any ideas on this topic.  

In a standalone app I'm developing, I'm wanting to use a bluetooth input device to drive inputs (like a bluetooth keyboard).  I've laid out the input key I want in the UE5 input Action Manifest, and the device I want to use just acts as a keypress for that key ("Hyphen" button).  I've tested the key out in the UE5 editor (I'm using the OpenXR 2-in-1 plugin), and using my bluetooth input device I'm able to call the event I want.  But when I package an android build and sideload it onto my Vive XR Elite, initiating the input from my device doesn't call the event.  

The XR Elite registers the input device as a keyboard and when I pull up the virtual keyboard in the headset, it outputs the key I want, but t can't seem to call the event in my application.  So my question is are there any vital steps or permissions I need to add to my project or configure in my headset in order for bluetooth devices to work in android applications?

Thank you all in advance!

Link to comment
Share on other sites

  • 3 weeks later...

Could you maybe explain how you got this working?

I am currently trying to achieve the same. We want to have a standalone VR application for Vive Focus 3 where an external user can guide the experience by using a bluetooth keyboard directly connected to the Vive Focus 3.
I'm currently simply using the UE5.1 WaveVR Sample project and added an input button for when the "G" key is pressed. When i play-in-editor the input key from my PC's keyboard gets passed along correctly. But whenever i try to replicate this in an android build, deployed to the device, none of my keyboard inputs seem to be registered by Unreal.

Did you have to do anything special that i'm missing?

Link to comment
Share on other sites

Hi @GvS481

Did you pair your bluetooth keyboard to your headset instead of your PC?  That could be the reason if you were testing using Vive Business Streaming/DirectPreview.  So try and doublecheck if your keyboard's paired to the proper device.  Hope this helps!

Edited by VincentCXR
Link to comment
Share on other sites

I made sure to check what outputs are going out using the Vive Browser's keyboard to see if my inputs were correct to test if it's paired properly first.  

One thing I can probably suggest is checking if the Bluetooth permissions are enabled in your Android settings.  That was one other thing I tried to check as well.

Under Platforms in Project Settings, scroll down to Advanced APK Packaging

in Extra Permissions, type in android.permission.BLUETOOTH and/or android.permission.BLUETOOTH_ADMIN 

The image at the bottom provides what I've tried to get it to work in case you need an example.  For a full suite of android permissions to consider, take a look at https://developer.android.com/reference/android/Manifest.permission

Hope that helps!


Edited by VincentCXR
Link to comment
Share on other sites

Went through your exact steps but sadly it's still not working. I made sure to double check if the permissions were valid using the CheckAndroidPermissions nodes and they were indeed allowed. Was there maybe anything else you have done?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...