Jump to content

Unable to Setup Marker based scene alignment in LBE map configuration on VIVE Manager


Recommended Posts

Hello, I'm unable to start the Marker based scene alignment in the VIVE Manager app. I already have a map setup and working with Marker Based Drift prevention and everything else in the Enterprise Features section of the app works fine except scene alignment. When I attempt to use Marker based scene alignment I'm met with the "Preparing for Scene alignment" pop up message and it sits there for a couple of minutes until a new pop up message states "Identify map failed: Unable to identify the map, please check if the procedure and location is correct" which it is. Has anyone else had this issue? I've searched the forums and docs and I haven't been able to find anything.

Both the headset and app are on the latest versions and I've tried on both android and IOS. I've also tried while online and offline and I've tried right after making a new map but nothing has made a difference so far.

If anyone has any experience with this issue or any ideas on how to move forward please let me know.

Link to comment
Share on other sites



Sorry to hear you're having an issue with marker based scene alignment. 

The marker may not be recognized in this case, which can be something like not being enough contrast to pick up the image. Printing out the marker and having appropriate lighting would be important to ensure that the marker is picked up. This is a professional way of saying: when i prototype things on my computer or phone screen, my coworkers have to remind me to print it out to avoid errors (or at least change the contrast setting on the screen, but this sometimes isn't enough).

The bit that threw me from this specific message was "Unable to identify the map, please check if the procedure and location is correct", which to me suggests that the marker_list.json file does not have this marker associated with the map

Link to comment
Share on other sites

I agree with the diagnosis. The weird part is that these pop up messages happen as soon as I launch the Marker based scene alignment and I never get the option to select a marker file for the scene alignment. It never gets to that point. I assume based on what I've seen that you select the file for the scene alignment from the Marker Based Scene Alignment menu, and not during the map creation like the drift prevention?

Link to comment
Share on other sites

  • 2 months later...

Hello @Alex_HTC

I'm also having an issue with scene alignment. I'm testing first with only one marker in a tiny room ( 4x4), I built a test scene on Unity and followed VERY carefully and multiple times the entire process for map creation, aruco creation and placement, etc.
I'm using the focus 3 through VBS and I followed the tutorial for the debug message to send to openVR driver.
It works but badly.
Basically what i get is a scene that seems well oriented (will be better when i do with 2 arucos)  but the placement is wrong.
I placed a marker on my virtual scene and the offset between the real-world one and the virtual one is at least 10cm on one axis and around 20-30 on the other.
here are some screenshots/videos



Do you have any idea what's going wrong ?

I'm using VBS 1.13.8b and corresponding app,
steamVR 2.2.3
unity 2021.3.4f1
and so far every single tests i did with arucos has been unsuccessful.

Any help is Welcome,



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...