Jump to content

UE5.3 3D VR Template game uploads to XR Elite as 2D game and won't run


Recommended Posts

Hi @DRSpearing,

Could you double check Default_5_3_2.uproject, is ViveOpenXR enabled?

image.png.ebcc86a1ef32c07a0012ff71131deb81.png

File path: C:\Users\DanSpearing\Development\Unreal Projects\Templates\Default_5_3_2\Default_5_3_2.uproject

If yes, could you try package our ViveOpenXRGame sample?

Is the issue still exist?

Link to comment
Share on other sites

Good morning.

Yes, the ViveOpenXR plugin is enabled. 

I built and installed the ViveOpenXRGame sample and it worked. I'll compare my project settings with the example when I get home tonight.

One thing I noticed on my initial comparison is that in the ViveOpenXRGame, the target seemed odd since the XR Elite is a version 10 operating system. Maybe I don't understand this setting.

image.png.df252a689c78d1be3ac8e5660d5ddb62.png

However, I changed my project to use this setting and that didn't work.

Thanks for your assistance. I'll keep you posted.

Link to comment
Share on other sites

Posted (edited)

I compared the project settings and modified the very few things that were different. Mainly packaging for Shipping vs Development. Still couldn't get the UE VR_Template to deploy to the headset correctly. I did notice that the ViveOpenXRGame sample packages with an extra file that starts with AFS_:

image.png.6a0524bf3019ed0421fc1a898ea24d44.png

Not sure what that is.

I tried another approach, and that was to add the VR content from the UE VR_Template project to the ViveOpenXRGame sample. I could get that to build and deploy but have yet to get "VR" working.

I've had this workflow working in UE 5.1 (on another computer though), but not in UE 5.3. There must be some incompatibility with the sample project and the Vive headset that I can't seem to find.

If the "released" version of the Unreal Engine 5.3 ViveOpenXR plugin was tested against the Unreal Engine 5.3 example VR template project, I would really like to know if it worked and what the secret was to get it deployed.

Anyway, I'm giving up for now and going to try something else.

Thanks for the assist!

 

Edited by DRSpearing
Link to comment
Share on other sites

It does deploy and play in the HMD. It just doesn't track with the headset or track the controllers with the VR pawn. I probably need to do more work on the project to get the VR aspects working. 

I would really like to know how to get the UE 5.3 version of the VR Template working and deployed to the Vive XR Elite. 

Link to comment
Share on other sites

Project sent.

I tried to launch the project to the headset through Unreal Engine. I saw the same 2D window in the headset and  I received the following errors:

image.thumb.png.df46850c2cab1fd8f4a8ec790cc12d92.png

I do have the OpenXR plugin enabled in the project and the ViveOpenXR plugin enabled. 

Link to comment
Share on other sites

Posted (edited)

Does anyone have any ideas? I've been working on this issue for almost 3 weeks now. Support has been trying to assist. I've sent them my project and they can build and run it.

I'm running Windows 11 and it appears that the Vive OpenXR plugin is not working because if I disable it in my project I experience the same issues. 

Has anyone used Windows 11, UE5.3.2 and the Vive OpenXR plugin on an XR Elite with any success?

When I build:

ATHelper: Packaging (Android (ASTC)): Error [GENERAL | xrCreateInstance | OpenXR-Loader] : LoaderInstance::CreateInstance chained CreateInstance call failed
UATHelper: Packaging (Android (ASTC)): Error [GENERAL | xrCreateInstance | OpenXR-Loader] : xrCreateInstance failed

Warning: Required extension XR_HTC_passthrough is not available

Warning: Required extension XR_HTC_hand_interaction is not available

Warning: Required extension XR_HTC_facial_tracking is not available

Warning: Required extension XR_EXT_eye_gaze_interaction is not available

Thanks!

Edited by DRSpearing
Added additional information
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...