Jump to content

No display on HTC Vive Cosmos Elite


Recommended Posts


Let me start with my configuration:

SteamVR Version: 1.10.32 (1584924836)
Viveport version:
OS: Windows 10 (
GPU: Gigabyte GeForce GTX 1080 Ti Gaming OC 11GB GDDR5X (352 bit)
VBIOS version:
Graphic card drivers version:
Nvidia drivers version: 445.75
Headset's firmware version:

I can't get the device to work. There is constant red light on the headset and it displays no image (black screen). From time to time, Vive Console displays one of the errors: 003, 210 (especially this one) or 218, but after several restarts it says everything is OK but still no display.

The controllers and tracking work fine. I was able to configure the room and when I display the VR view on PC, I can move around the headset and controllers to see proper reaction.

When I turn off the Direct Mode in SteamVR settings, headset displays my desktop but it's upside-down. It makes me think that the headset is not broken. After turning Direct Mode back on, I get the black screen back again.

Sometimes, while booting VR, the LED flashes green for a brief moment, the sound switches to headset's headphones and after a second or two, the LED  turns red and the black screen remains.

Things I've tried and didn't help:
- Updating everything including MOBO drivers, GPU drivers, Viveport, SteamVR, Windows to the newest versions, even tried BETA versions
- Disconnecting and reconnecting every cable available
- Switching USB and DisplayPort ports
- Rebooting both PC and VR headset multiple times
- Reconfiguring the whole kit from scratch several times
- Reinstalling the whole software from scratch
- Changing PC power management
- Disabling the firewall and antivirus
- Enabling motion compensation

I've contacted both Vive and SteamVR support but I only got a bunch of generic advices I also found on the internet before.

Is those 2 topics the issue seems to be similar to mine:


In those topic updating the VBIOS helped but I'm not sure how and if I can update mine.

I go to the Aorus Engine's preferences and click "Check for BIOS updates" in the "VGA" tab but it says there are no updates available. Also according to this site: https://www.techpowerup.com/vgabios/?architecture=NVIDIA&manufacturer=Gigabyte&model=GTX+1080+Ti&version=&interface=&memType=GDDR5X&memSize=11264&since= there is no newer BIOS for my GPU.

I attach SteamVR system report. I can also share the result from Vive Diagnostic Tool but I need a temporary login and password to run it.

I lost over 10 hours trying to set it up and I'm getting pretty desperate about it...

Thanks for any help help in advance!



Link to comment
Share on other sites

Thanks @Nivelis. Just submitted a report to our ENG team to look into this. Hang tight. 

Could you also share your Ticket No. from your engagement with our customer service? I want to make sure we have all the relevant data for this issue. 


Link to comment
Share on other sites

It worked, thanks!

I don't know if it's relevant or helpful for you now but before you sent me the code to the test build I've also tried to fresh-install Windows 10 on another drive and it also seemed to resolve the issue. Nontheless I appriciate I can play on my "normal" instance of the system now.

I must say I'm impressed by the quality of your support and the fact that someone technical actually spent some time to take a closer look at the particular case instead of saying "Try to restart your PC" or "Unplug and plug your device" over and over again. From my experience with supports - it is not always a case. Keep up the good work 🙂

  • Like 2
Link to comment
Share on other sites

On 4/10/2020 at 1:54 AM, C.T. said:

Hi @Nivelis

We have a possible lead on the error, I will PM you a test build to verify the result after internal review soon. 
Please bear with us.


Hi I'm having the same issue with mine. Can I have that build too?

Link to comment
Share on other sites

10 hours ago, Corndog said:

Hi I'm also having problems with this.


Trace no:


Could you run Cosmos Elite installer again to make sure the SW has been installed completely?
We discovered that there might be some missing from the file.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...