Jump to content
Happy Holidays! Limited Staff Responses: 1/20 - 1/31 ×

Unity APKs install but won't play on Vive Focus 3 - no issues for same VR app on Quest 2 and Pico Neo 3


nickmoseley
 Share

Recommended Posts

I design and develop VR Training apps for the Health sector in the UK and have developed a test version of a new app using the XR Interaction Toolkit using Unity 2020.3.25f1 LTS which I can build and run on both Quest2 and Pico Neo 3 VR headsets without any problem. However after following all of the documented Vive instructions - installing the Vive Wave XR Plug-in with recomended Player settings, the resulting APK installed following the https://business.vive.com/uk/support/focus3/category_howto/installing-apk-on-headset.html instructions, the VR app just shows as a black landscape block and then a portrait transparent block with the Exit/Close X on the bottom. Also happens for a simple scene with just a camera and cube in. I was hoping to run a comparision on the new app across the three headsets and it will be a shame if I can only do with the Quest 2 and Pico Neo 3 headsets for which the VR app runs really well, there are much more detailed and simpler instructions  and I experienced no issues.

Here are screengrabs showing the issue and Unity settings.

image.png.0d5b1b542c2a7f16a7e99b33699a9dd3.png

 

image.png.361365603c995a14324e6e8d09fd655f.png

image.png.753f526c427fbd6bb5a23c54dcb7a5f0.png

image.png.93649949fdb9883b6848096ec63b8ff1.png

image.thumb.png.f11a5b6192c72ca2dc816eb2334dc767.png

image.thumb.png.aaa4d15ff6f25240d612e3f25e6f5bc0.png

image.png.b8fa6070ddbe6569d36d5c3dd27b6a89.png

 

 

Link to comment
Share on other sites

Hi Chengnay. Thanks for the suggestion. Deleting the AndroidManifest.xml now installs apps into my library but shows a fixed view animated image with a fixed white 'beam' that doesn't change when I move my head or show the controllers.

image.png.891f5366bcfbb8abaa926e39832b85f5.png

I have my Oculus headset attached and set up for checking in on PC in Play mode and it works fine when I run the scene with this. Note that Oculus is not selected in the Android settings for XR Plug-in Management.

Same issue occurs in this simple test scene with just a cube and XR Rig.

image.png.dd2e6c6cbfcbd99acc504a608eebdd3b.png

When I test it with my Rift in Play mode on the PC I can move my head and the view changes correctly. When I build the scene and install it on the Vive Focus 3, I get the same fixed view issue with a 'beam'.

image.png.b898bd667590a921a015b8dedea6c11e.png

Link to comment
Share on other sites

Thanks Chengnay. I understood that Vive Wave was now compatible with the Unity XR Plugin Management and the XR Interaction Toolkit, but it looks like the new action-based rig doesn’t work properly on the Vive Focus. I was hoping to create a project that I could deploy easily across different stand alone headsets, but this doesn't now appear to be possible for the Vive Focus 3. I need to press on now with the design and development of the app and will stick to building for just the Quest and Pico Neo 3 for now. Thanks for your help on this.

Link to comment
Share on other sites

@nickmoseley  I had this same issue but figured it out using this thread. Had to make a script called WaveDeviceLayouts.cs found in that thread and then add the input action for position/rotation of the controllers/HMD. Also had to use the unity specific TrackedPoseDriver

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...