Jump to content

One Controller will just not track at all


Recommended Posts

@Rich_BBVR - Which team are you contacting at Vive for support on this? This is definitely an enterprise-use case scenario and not something standard support would be able to effectively support - it would fall to enterprise support at that scale (support.enterprise@htc.com).

If you're truly trying to run 20 kits at once that would mean there would be upto 80 Bluetooth transceivers activated in the space (There are 2 per each HMD and 1 in each of the two 2 controllers). You're going to hit BT co-channel interference with that many Bluetooth devices in a room, regardless of what kind of BT devices you're deploying. BT all operates on a narrow slice of ~2.4-2.48Ghz spectrum - every single BT device in your environment is competing to broadcast over each other because the BT spec simply has a narrow RF spectrum upon which all devices are expected to operate. VR controllers are especially high bandwidth and have tight latency requirements.

To add to the mix, 2.5Ghz is directly adjacent and any 2.5Ghz WiFi activity in your space will inherently decrease your signal to noise ratio and introduce additional noise in your environment - I'd recommend all commercial installations past a certain scale to disable all 2.5Ghz broadcasts they can control and strictly broadcast 5Ghz for WiFi as it will improve the stability of your bluetooth devices. Other control systems like Oculus and Knuckle controllers fundamentally use the same ~2.4Ghz BT protocol - they'll add to your maximum device count and add to the co-channel interference problem - any device that uses BT will contribute to co-channel interference if it's within range.

Overall the max number of BT devices you can support in your space depends on the types of devices your using (their , your RF background (specifically 25Ghz WiFi and other BT devices), and the params and materials involved in the environment itself (which affects things like signal propagation). There isn't a lot of resources on this because few arcades and installations in the world are trying to drive this may devices in a singular space.

  • Like 1
Link to comment
Share on other sites

@VibrantNebula Thank you so much for your reply! I have been in contact with the enterprise team over the past month. There are many variables and I'm sure they are busy, therefore, I have not been able to get a straight answer from them. Your response does make a lot of sense and explains the randomness we see in connection and tracking. To clarify, the maximum number of systems we have in our current location is 14. We are opening a second location with 7 systems in just a few weeks and another with 6 in just a couple months. We do have other peripheral devices that run off WiFi (speakers, lighting, etc). I have been told those are running off 5GHz, though I am going to confirm tomorrow. BT has been disabled on each PC. We have a tracking puck and webcam that connect via USB to PC. 

It sounds like I need to do as you suggest and eliminate as many devices operating over BT and determine if 2.4GHz Wifi is enabled. It will be interesting to see if there is anything we can do to improve the environment. I will post any significant findings for other's reference if I find anything. 



Edited by Rich_BBVR
Link to comment
Share on other sites

  • 1 year later...
  • 2 months later...

Hi all, 

When you tried everything do the following.

Get a Phillip's screw driver and a T5 Torx screw driver (Not a screw Bit) and open the controller.

Reconnect the ribbons marked in yellow. (They can get lose when the controller was dropped on the floor) 

Follow this manual till step 8 HTC Vive Controller Front Panel Buttons Replacement - iFixit reparatiehandleiding

Good luck!


Link to comment
Share on other sites

  • 1 year later...
On 11/27/2020 at 1:18 PM, Jsmith9206 said:

Did anyone ever get a solution to this issue? I have had this problem for over a month now and I really don't want to buy another controller for $125... any assistance would be helpful. I have tried all the suggestions so far with no luck. 


Have a look at this, people are finding it's a USB audio conflict, corrected by choosing different audio output.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...