Jump to content

Disable headset sleep/standby


Recommended Posts

Neither setting the idle time up nor changing to beta steamvr fixed my problem. I can sporadically get it working by uninstalling steam vr entirtely and unplugging my second monitor. Quite frustrating for such an expensive piece of hardware to not work for a couple of weeks.

Link to comment
Share on other sites

  • Replies 75
  • Created
  • Last Reply

I have the exact same problem.  Usually a full on PC reboot resolves.   The headset will go to sleep within seconds of SteamVR loading and not recover, I have downgraded nvidia drivers from 390.77 to 390.65 which the problem appeared after the intial upgrade to 390.77 but I cannot remember.  I have had one strange behavior that seems to tie in, when a controller goes to sleep and the HTC screen goes to sleep and SteamVR is restarted I get a 3rd controller populate sometimes all 3 controllers will show up green but sometimes 1 will be greyed out.  Sometimes rebooting the HTC vive helps but it has caused SteamVR to be in a state of funk that requires full on system reboot to recover.


Within the last 20 minutes, I have switched to Steam VR Beta, enabled 10 min idle sleep timer, disabled power management.  I am crossing my fingers!


Link to comment
Share on other sites

I think the battle is over.  After a full reinstall of the nvidia graphics drivers I am no longer having issues with the Vive going to sleep and not waking up.  I have performed all the configuration changes listed above and will keep them as they are but so far I have good reports, normally it doesn't make it through the night without problems.  What I did notice when doing just a downgrade or upgrade of the graphics drivers the Vive still had problems not waking up requiring a system reboot to resolve.  When I did the full driver reinstall and booted the Vive via steam VR, there were no problems at all and has remained that way without a system reboot!

Link to comment
Share on other sites

Hey John,


Questions are good!    I was running nvidia 390.77 drivers when the issue first happened.  I downgraded to 390.65 hoping it would resolve and it didn't.  It wasn't until I upgraded back to 390.77 with a clean install that resolved the issue.  I have been able to launch SteamVR and Vive many times without failure and it made it through the night which it never does since the issue happened.  


I can confirm I am running SteamVR beta, and Steam Beta.

Disabled power management via the SteamVR app.

Changed sleep time from 5 seconds to 10 minutes.

Disabled and renabled direct mode.

Restarted steam numerous times when issue happened with only way to resolve was a full system reboot.

Running nvidia 390.77 drivers with clean install (seemingly resolved issue).  


I will be gone for a long weekend this will be a good test to see if all is good when I return Sunday.


Thank you!


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...