Jump to content

Update: Compatibility issue causes BSOD/Freeze on select AMD systems


Recommended Posts

  • 2 weeks later...
  • Replies 44
  • Created
  • Last Reply

Top Posters In This Topic


Thank you for the hotfix and for trying to fix the issues related to this product, it seems that some users issues are solved :)


Unfortunately it doesn't solve the issue in my case as the card is not detected by the system (Threadripper 1950X / ASrock X399M Taichi).


I'm having a "Not ready (101) - WiGig card not found" error message.

I already tried all PCIe slots and updated the bios to the latest version without success, I believe it's a low level issue as the card is not visible in Linux either.



Link to comment
Share on other sites

I have similar issue. My PCI-E card won't detect in PCI-E Gen 3.0 slot connected to my Ryzen 2700X CPU, but works fine in PCI-E Gen 2.0 slot connected to X470 chipset. Intel wireless card is not visible in device manager on Windows, and not listed by lspci on Linux when in CPU PCI-E Gen 3.0 slot. Any other device like GPU, Sound Card, USB Host controller, etc. works fine in that slot.

  looks like in your motherboard X399M Taichi all PCI-E x16 slots are connected to CPU.

Link to comment
Share on other sites


The card doesn't show up indeed, I tried all the slots of my motherboard, this is not really a new issue.


I was hoping that the new hotfix might solve it (I did the firmware upgrade using another computer), but it did not (it seems like the firmware upgrade was on the heaset side so it would have been unlikely ... but who knows).


The motherboard is working fine as far as a know, this really seem to be related to an incompatibility between the WiGiG adapter and PCI-E slots connected to the CPU.



You are correct, I have tried all the slots and tried to change the BIOS settings as well (PCI-E speed, ...) no luck so far.

If it's fixable with software,  this would likely require a new firmware for the WiGiG adapter and / or an updated BIOS.

Link to comment
Share on other sites


Were you able to get the card to work on another PC? It might just be the card is dead. PCIe standards probably aren't going to change with a firmware update. Even if there was an firmware/driver incompatibility, it just should show up as an unknown device, but it would show up. The only reason I think it would simply not register is either the PCIe bus is broken on the PC (unlikely if other cards work) or the card itself is damaged and unable to interface correctly.

Thank you,
-Jack S

Link to comment
Share on other sites

Recently I played a bit with BCLK on my motherboard. If BCLK is outside the 97-109 MHz range WiGig card just disappears from my system (become undetected by OS). When BCLK within that range, it works fine.


There is something wrong with PCI-E interfacing of that card.

Link to comment
Share on other sites



"Were you able to get the card to work on another PC?"


Yes, that's how I upgraded the firmware with the latest fix, unfortunately this PC is far from beeing powerful enough to run VR applications. The PCI bus on the motherboard/CPU is not broken either, I'm able to use these slots with other cards, there is really some kind of incompatibility.


Actually I recall that initially my system even refused to POST (error code 94 IIRC) when having the WiGiG adapter inside (using the original BIOS v1.10), after upgrading the BIOS it now boots properly but the card is just not visible.


This seem to be a known issue, from what I could read the workaround would be to use a PCI-E slot that is not connected directly to the CPU controller, but unfortunately there is no such slot available on my motherboard model.


That's very interresting, thanks for this information !

It's the first time that I hear about a potential link between the BCLK speed and this issue, maybe I'll try to tweak a bit around with it to see if this brings any improvement.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...