Jump to content

Direct preview doesn't preview in the Focus 3 headset .... only in the Editor window.


Recommended Posts

  • 4 months later...
12 hours ago, dev_imag-ing said:

Hi @Dario ,@Alex_HTC, @C.T.

DirectPreview does not work.

Neither in USB nor WiFi mode. The connection just times out. What is your setup to make this work ?

Also, care to explain how to use VBS ? Because it only shows the basic SteamVR layout in the headset, but does nothing when Unity enters Play Mode.


Thank you.

I've just checked with wave 4.4 r8 release with Unity 2020.3.32f1, both should send out HMD pose just fine. 
A few places need to check before it can work. 
1. build settings -> need to switch to android 
2. project setting -> XR plug-in management, PC WaveXR also needs to be enabled.
3. if you go with USB, then just start the direct preview APK, and hit play
    if you go with Wi-Fi, please make sure you have entered correct IP of your Focus 3, others for target device. then start the preview server, start device APK.
(it's okay to see connection time out from Focus 3, it will pick up automatically.)

let me know if it works out for you

Link to comment
Share on other sites

Sure. When moving the camera in the editor, it does work in the headset. But the headset is not moving on his own, and each eye has a different image of the scene. I tried using those 4 different cameras :


I tried using 2019, 2020 and 2021 version


every parameter has been  tried in wi-fi

WaveXR is ticked on PC and Android platform

directpreview is enabled

Apk has been installed, removed and reinstalled multiple time

It would be really helpful if you help me find the solution.

Thanks in advance


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...